Using Sample Child Theme – Blog Template MIssing

Community Forums Forums General Discussion Using Sample Child Theme – Blog Template MIssing

This topic is: not resolved

This topic contains 16 replies, has 3 voices, and was last updated by  genevishgraphics 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #3752

    genevishgraphics
    Participant
    Post count: 52

    I noticed that using the Sample Child Theme – There is no Page Template to select under Page Attributes. So I thought if I added a page_blog.php to the child theme folder I would now have a template to select for the blog Page. And yet there is still nothing appearing under Page Attributes. What am I doing wrong here?? The whole point is to have the blog page show a sidebar and it will not. It is showing the default layout I have chosen under the Genesis Settings, even though on the page it self I have selected it to have a two column layout

    LINK

    #3756

    Anita
    Participant
    Post count: 7565

    You need to look under the templates. To create a blog page – You Add New Page, then look on the right and then select the Blog template. Then save it. Add it to your menu and then it will show up all of your blog posts.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #3759

    genevishgraphics
    Participant
    Post count: 52

    That is just the thing – THERE IS NO PAGE ATTRIBUTES – nothing. nada. no where to select page template – blog. Even though I have uploaded a page_blog.php. Still nothing.

    #3762

    Anita
    Participant
    Post count: 7565

    Oh, I see now – you need to scroll down and select the PAGE LAYOUT towards the bottom. You have that set to FULL WIDTH. Change it by adding a layout with a sidebar.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #3764

    genevishgraphics
    Participant
    Post count: 52

    NM – I was missing info in the header of the style sheet somehow!!!

    EDIT:::: Can select BLOG TEMPLATE now I added the missing info in the style sheet header. HOWEVER the blog is still showing up as full-width content even though I have TWO COLUMN selected in layout of the page!!! GOING NUTS!! Never had this problem before :(

    #4688

    genevishgraphics
    Participant
    Post count: 52

    Can select BLOG TEMPLATE now I added the missing info in the style sheet header. HOWEVER the blog is still showing up as full-width content even though I have TWO COLUMN selected in layout of the page!!! GOING NUTS!! Never had this problem before 

    #4692

    Anita
    Participant
    Post count: 7565

    Can you post the header code you placed in your template?


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #4699

    genevishgraphics
    Participant
    Post count: 52

    I just copied the Genesis theme core blog_page.php into the child theme folder. From my understanding, I shouldn’t have to do that to have the blog page show properly. Could this be happening because I have the front page set to a static page?

    #4702

    Anita
    Participant
    Post count: 7565

    Yes, try removing that and see if that helps.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #4706

    genevishgraphics
    Participant
    Post count: 52

    No Dice. Still showing as full content, no sidebar still. I have never used the sample child theme before, I have used lots of Genesis child themes and never had a problem like this. Just so strange. I set another page, not the blog page, to show the sidebar, and it shows up just fine. So the problem is just with the blog page

    #4707

    Anita
    Participant
    Post count: 7565

    Can you post the header information you put in your new template?


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #4720

    genevishgraphics
    Participant
    Post count: 52

    Not sure what you are asking for?

    #4725

    Anita
    Participant
    Post count: 7565

    Can you post a link to your site? Also, in the page template – how do you have it set up – content-sidebar or sidebar-content-sidebar, how is it set?


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #4731

    genevishgraphics
    Participant
    Post count: 52

    I posted it at the very top of the thread, I have Genesis set to Full Width, but the blog page set to sidebar content

    #4745

    wowgrafix
    Participant
    Post count: 10

    I am having the exact same problem with the Serenity Theme, but I don’t even know enough about coding php to understand what you are saying as to how to fix it… can you guys / gals be more specific as far as how to get that “Page Attributes” box back so that I can add a blog page?

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.