web.config for permalinks, 2 sites running

Community Forums Forums Design Tips and Tricks web.config for permalinks, 2 sites running

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  myersbr2 11 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #56290

    myersbr2
    Participant
    Post count: 17

    I have two separate installs of WP 3.5.2 on a Windows 2008 server (sure wish it were Linux). Both sites work, and on the primary site, pretty permalinks works. The web.config of the primary site (http://www.strongwell.com) is as follows:

    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name=”wordpress” enabled=”true” patternSyntax=”Wildcard”>
    <match url=”*” />
    <conditions>
    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />
    </conditions>
    <action type=”Rewrite” url=”index.php/{R:0}” />
    </rule>
    </rules>
    </rewrite>
    <staticContent>
    <remove fileExtension=”.eot” />
    <mimeMap fileExtension=”.eot” mimeType=”application/vnd.ms-fontobject” />
    <remove fileExtension=”.ttf” />
    <mimeMap fileExtension=”.ttf” mimeType=”font/ttf” />
    <remove fileExtension=”.otf” />
    <mimeMap fileExtension=”.otf” mimeType=”font/otf” />
    <remove fileExtension=”.woff” />
    <mimeMap fileExtension=”.woff” mimeType=”font/x-woff” />
    <remove fileExtension=”.pdf” />
    <mimeMap fileExtension=”.pdf” mimeType=”application/pdf” />
    <mimeMap fileExtension=”.mp4″ mimeType=”video/mpeg” />
    </staticContent>
    <tracing>
    <traceFailedRequests>
    <add path=”*”>
    <traceAreas>
    <add provider=”ASPNET” areas=”Infrastructure,Module,Page,AppServices” verbosity=”Verbose” />
    <add provider=”WWW Server” areas=”Rewrite” verbosity=”Verbose” />
    </traceAreas>
    <failureDefinitions timeTaken=”00:00:03″ />
    </add>
    </traceFailedRequests>
    </tracing>
    <security>
    <requestFiltering>
    <requestLimits maxAllowedContentLength=”10000000″ />
    </requestFiltering>
    </security>
    </system.webServer>
    </configuration>

    The other site is in a subdirectory of the main site called (http://www.strongwell.com/trainingnew) and it works fine but I cannot get pretty permalinks to work. I’ve tried NUMEROUS web.config options, but don’t know if I’m supposed to put a new web.config in that folder or add to the existing one here. Ideally, I want the configuration to be http://www.strongwell.com/trainingnew/%postname%/

    http://www.strongwell.com
    #73600

    Susan
    Moderator
    Post count: 9240

    I see you posted this a while back, so I hope you got your issue resolved. If not, come back and check in, and I’ll escalate it for you…


    Susan @ Graphically Designing I offer theme customizations I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #73691

    myersbr2
    Participant
    Post count: 17

    Still unresolved. I gave up after trying everything I found online. I’d greatly appreciate some help!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.