Where to define the Homepage in Executive Theme

Community Forums Forums General Discussion Where to define the Homepage in Executive Theme

This topic is: not resolved

This topic contains 7 replies, has 2 voices, and was last updated by  braddalton 1 year, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23265

    CharlieL
    Participant
    Post count: 24

    Can´t find a place to define the Homepage in Executive Theme.

    Usually, I use to define it in the drop-down menu just below the Update-button at the page-editor.
    The only options available in my Executive Theme are Standard, Archive, Blog and Landing but no Homepage.
    And there is nothing said about this in the general install instructions for this Theme.

    Please advise me.

    #23270

    braddalton
    Participant
    Post count: 7458

    If you populate the home page widgets they will display the content. Otherwise you blog posts will display on the homepage.

    You can change that in the Reading Settings.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #23306

    CharlieL
    Participant
    Post count: 24

    Thank you for your advice.

    However I made changes in the Reading Settings but it did only work if I choose the Blog.
    In that case the Slider showed up. But I would prefere to have a static page instead. I created
    a new page and added only a headline, nothing more.

    Then I chose that page as a static  homepage, and the blog page for the posts. I expected that
    the Slider would show up on the homepage, but not. I have looked through all my settings
    and I have also changed to other pages in the settings but still the Slider don’t show up in the right
    place. It  will stay on the blog page even if it not was choosen as the static homepage.

    As I understand it, I shall choose both a Homepage and a Blogpage to get it working (because the
    other option is only the Blogpage). But the Slider still stays at the Blog-page..

    Any suggestions?

     

    #23315

    braddalton
    Participant
    Post count: 7458

    Use the default settings and simply populate the top featured widget with the GRS.

    Don’t make any changes to the Reading settings


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #23362

    CharlieL
    Participant
    Post count: 24

    Sorry, but I am more confused now. There have been stuff in the widgets Home-Slider, Home-Top, Home-Call to Action and Home-Middle all the time. But nothing of this will show up if I choose “Your latest Posts” (freely translated from Swedish). But if I choose a Static page and then the Homepage plus the Blog page the Slider will show up on the Blog page. But never on the Homepage.  If I leave the Blog-page empty and only have it set to Homepage the the Slider will not show up at all, nowhere.

    For the type of Content I have choosen Posts in the Slider Settings (menu Genesis >) As I would like to show Posts in the Slider on the Homepage.

    Could you please elaborate a little more on this so cause and effect might be more obvious to me?

    #23376

    braddalton
    Participant
    Post count: 7458

    Sorry, but I am more confused now. There have been stuff in the widgets Home-Slider, Home-Top, Home-Call to Action and Home-Middle all the time. But nothing of this will show up if I choose “Your latest Posts” (freely translated from Swedish).

    Yes, exactly.

    But if I choose a Static page and then the Homepage plus the Blog page the Slider will show up on the Blog page. But never on the Homepage. If I leave the Blog-page empty and only have it set to Homepage the the Slider will not show up at all, nowhere

    No. You don’t choose any page from the Reading settings if you want to use the widgets on the home page. Leave the settings as they are out of the box.

    If I leave the Blog-page empty and only have it set to Homepage the the Slider will not show up at all, nowhere

    You simple add a custom link to your blog page in the nav menu.

    Any posts you publish will display on this page regardless of where it is.

    You DON’T set anything for the home page. It displays by default when you populate the widget areas. If you don’t populate the widget areas, it displays your blog posts.

    Can you post a link to your site please.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #23482

    CharlieL
    Participant
    Post count: 24

    Thank you for your comments Brad. I will try to apply your advice to the site.

    I can give you full acess to the site if you write me in private to: donatcomartdotse

    However, the Slider did show up once on the homepage in Firefox and disappeared again
    later without any changes. That made me suspect Firefox. Maybe some add-ons could
    interfere here. So I checked in Opera and it worked.
    I guess now that I have been fooled a bit by Firefox. Ought to have checked in other
    browsers as well.

    So now it works in Explorer, Chrome, Safari and Opera and somehow in Firefox.
    Sorry for my confusion.

    #23491

    braddalton
    Participant
    Post count: 7458
    This reply has been marked as private.
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.