cdils

Forum Replies Created

Viewing 15 posts - 316 through 330 (of 391 total)
  • Author
    Posts
  • in reply to: Comment boxes on uploaded media #18035

    cdils
    Participant
    Post count: 399

    I tried this code snippet from WPBeginner and it seemed to do the trick.

    function filter_media_comment_status( $open, $post_id ) {
    $post = get_post( $post_id );
    if( $post->post_type == ‘attachment’ ) {
    return false;
    }
    return $open;
    }
    add_filter( ‘comments_open’, ‘filter_media_comment_status’, 10 , 2 );

    You could place it in your theme’s functions.php file or wherever else you drop in your theme’s custom code.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: eNews Extended widget & MailChimp Integration #18021

    cdils
    Participant
    Post count: 399

    Hi there,

    For starters, just making sure you downloaded the new version of GEE from the WordPress repository and are not using the one that comes default installed with Genesis. :)

    The plugin author gives some detailed instructions here for integrating with MailChimp and getting the form action right.

    As far as the line breaks go, that’s going to be a CSS change either to the margin or padding of those elements. I looked on your site but couldn’t find the newsletter signup. Once you get it working, post a followup and I can help you troubleshoot the CSS.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: 3 Column Layout on the Home Page, AgentpressII #18017

    cdils
    Participant
    Post count: 399

    Hi Rab,

    For any page BUT the home page, AgentPress has a layout options for full-width, content-sidebar, or sidebar-content-sidebar. To change that, go to any individual post, listing, or page editor screen and look for “Layout Settings”. If you want the same exact setting on all posts/pages/listings, you can change it universally at Genesis > Theme Settings and look for “Layout Settings.”

    Now, if you’re not talking about sidebars and want the content area itself to contain one more columns, you can use these content column classes.

    Things get a little trickier on the home page since there are multiple widget areas to deal with and their corresponding CSS specs. The easiest solution would be to go to Settings > Reading and change the “Front page displays” from your latest posts to a static page. Doing that will cause the default AgentPress home page template (home.php) not to show.

    The alternative solution is to dig into the code and modify the structure of the home page. Depending on your level of comfort with PHP and CSS, you may or may not want to tackle it.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: Major site update with Metro: comments welcome #18006

    cdils
    Participant
    Post count: 399

    It is one sharp looking theme and your site is looking nice! You can go to http://www.studiopress.com/responsive to see your site on different media screen sizes – very helpful to make sure any CSS modifications didn’t jack with the responsive elements. :)


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: pagination not working in Blog Template #18005

    cdils
    Participant
    Post count: 399

    I’ve read several blog posts recently about going when to use wp_query vs query_posts. Here’s a couple of them in case they might be helpful to you:

    http://wordpress.stackexchange.com/questions/1753/when-should-you-use-wp-query-vs-query-posts-vs-get-posts

    http://www.billerickson.net/customize-the-wordpress-query/

    Feel free to post followup questions if you want to muddle through anything together.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: How to move Post Date & Comments Link #17996

    cdils
    Participant
    Post count: 399

    Hi Erin,

    Open up functions.php and look for this bit of code:

    /** Relocate the post info */
    remove_action( ‘genesis_before_post_content’, ‘genesis_post_info’ );
    add_action( ‘genesis_before_post_title’, ‘genesis_post_info’ );

    On that second line, instead of ‘genesis_before_post_title’, you’ll want it to be ‘genesis_after_post_title’, like this:

    /** Relocate the post info */
    remove_action( ‘genesis_before_post_content’, ‘genesis_post_info’ );
    add_action( ‘genesis_after_post_title’, ‘genesis_post_info’ );

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: pagination not working in Blog Template #17990

    cdils
    Participant
    Post count: 399

    Hi Cathy,

    Can you post a link to a page using your page_blog.php template?

    Just to clarify, do you mean that your < Older Posts & Newer Posts links aren’t showing?

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: How to add a class to an image within loop #17698

    cdils
    Participant
    Post count: 399

    Are you using your own custom loop/query or using genesis_custom_loop to loop through your posts?

    You might take a look at image.php in the Genesis theme to see how it’s handling images. Looks like genesis_get_image_default_args is called in the genesis_get_image function, which uses wp_get_attachment_image (See how style classes are passed to this last function in the codex: http://codex.wordpress.org/Function_Reference/wp_get_attachment_image)

    I’m trying to be helpful and not send you off following rabbits. :) If that doesn’t get you going in the right direction, maybe you can post the entire contents of your archive page so I can see your function in context.

    Cheers,

    Carrie

     

     


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: Comments overlapping using child theme of Genesis #17697

    cdils
    Participant
    Post count: 399

    I didn’t see any comments on the page/post in your link. Can you post a link showing your problem?

    I’ll check with the theme author to see if she has any suggestions.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: Simple Hooks Error #17695

    cdils
    Participant
    Post count: 399

    I think you’re correct that it’s the custom code you’ve entered in the plugin and not the plugin itself.

    Line 25 should be the 25th line of custom code entered via the Simple Hooks plugin – Check out that line and see if it has a syntax error. Feel free to post the line of code here if you’re not sure.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: Firefox not displaying background color of sidebar #17694

    cdils
    Participant
    Post count: 399

    On your .sidebar element in the CSS, try changing display:inline to display:inline-block.

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: Custum type post with mutiple images #17656

    cdils
    Participant
    Post count: 399

    Hi there,

    How do I create a custom type that includes images in custom fields, either as picked from media og uploaded?

    When you create a custom post type, you don’t need to do anything special to accommodate the custom fields. You can add those after the fact. Bill Erickson and company wrote this code for custom mextaboxes that will allow you to add your custom fields in a nice metabox for your custom post type. It’ll present a nice layout on the post editor side.

    How do I show these posts in a special layout in the Genesis Framework?

    I’m assuming you mean how do you create a custom page template to show your post type and your custom fields? This post might be a good starting point. You can also do a Google search for “Genesis custom page template” and find some other great tutorials.

    See if that gets you pointed in the right direction and feel free to post follow-up questions. :)

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: How do I remove image link from grid loop? #17653

    cdils
    Participant
    Post count: 399

    Try removing this bit:

    ‘size’ => genesis_option(‘image_size’),


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.


    cdils
    Participant
    Post count: 399

    Hi there,

    Re-do your single and double quotes – looks like they are stylized and not plain.

    :)


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

    in reply to: style on Search page #15739

    cdils
    Participant
    Post count: 399

    Hi Mitch,

    Glad you were able to find a solution! My other suggestion would be to target the page using its body class (if you view the <body> tag on your search archives page, you should see something like <body class=”search

    Then you could target your CSS like:

    .search .hentry { foo: bar; }

    Naturally subbing in .hentry for whatever page element you’re trying to hit.

    Changing gears, the new format for StudioPress Community forums has definitely taken some getting used to. It’s moderated by other Genesis users as opposed to just StudioPress staff and meant to be a way for the community to share tips, tricks, etc. If you ever have a question that’s going unanswered, go to My StudioPress > Get Help and submit a help ticket. That’ll get answered by a staff member in a hurry. :)

    Are you on Twitter? You can also use the #genesiswp hashtag for conversations/questions!

    Cheers,

    Carrie

     


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I tweet @cdils.

Viewing 15 posts - 316 through 330 (of 391 total)