Kent

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 54 total)
  • Author
    Posts
  • in reply to: Enterprise Pro Home Top #128972

    Kent
    Participant
    Post count: 60

    Hi all. I tried this and it’s just not working for me. I dunno what I missed.

    My functions.php code:

    //* Register widget areas
    genesis_register_sidebar( array(
    	'id'          => 'home-top-left',
    	'name'        => __( 'Home - Top Left', 'enterprise' ),
    	'description' => __( 'This is the top left section of the homepage.', 'enterprise' ),
    ) );
    genesis_register_sidebar( array(
    	'id'          => 'home-top-right',
    	'name'        => __( 'Home - Top Right', 'enterprise' ),
    	'description' => __( 'This is the top right section of the homepage.', 'enterprise' ),
    ) );
    genesis_register_sidebar( array(
    	'id'          => 'home-bottom',
    	'name'        => __( 'Home - Bottom', 'enterprise' ),
    	'description' => __( 'This is the bottom section of the homepage.', 'enterprise' ),
    ) );

    My front-page.php code:

    add_action( 'genesis_meta', 'enterprise_home_genesis_meta' );
    /**
     * Add widget support for homepage. If no widgets active, display the default loop.
     *
     */
    function enterprise_home_genesis_meta() {
    
    	if ( is_active_sidebar( 'home-top-left' ) || is_active_sidebar( 'home-top-right' ) || is_active_sidebar( 'home-bottom' ) ) {
    
    		//* Force full-width-content layout setting
    		add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_full_width_content' );
    
    		//* Add enterprise-pro-home body class
    		add_filter( 'body_class', 'enterprise_body_class' );
    
    		//* Remove the default Genesis loop
    		remove_action( 'genesis_loop', 'genesis_do_loop' );
    
    		//* Add home top widgets
    		add_action( 'genesis_after_header', 'enterprise_home_top_widgets' );
    		
    		//* Add home bottom widgets
    		add_action( 'genesis_loop', 'enterprise_home_bottom_widgets' );
    
    	}
    }
    
    function enterprise_body_class( $classes ) {
    
    		$classes[] = 'enterprise-pro-home';
    		return $classes;
    		
    }
    
    function enterprise_home_top_widgets() {
    
    	genesis_widget_area( 'home-top-left', array(
    		'before' => '<div class="home-top-left widget-area"><div class="wrap">',
    		'after'  => '</div></div>',
    	) );
    	
    	genesis_widget_area( 'home-top-right', array(
    		'before' => '<div class="home-top-right widget-area"><div class="wrap">',
    		'after'  => '</div></div>',
    	) );
    	
    }
    
    function enterprise_home_bottom_widgets() {
    	
    	genesis_widget_area( 'home-bottom', array(
    		'before' => '<div class="home-bottom widget-area">',
    		'after'  => '</div>',
    	) );
    
    }
    
    genesis();
    

    Any thoughts? As it is, it breaks my homepage at my site http://www.kiersdev.com/pnbc1/

    Is it because I haven’t designated styles for the home-top-left and home-top-right widgets in my css?


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Enterprise Pro Home Top #128779

    Kent
    Participant
    Post count: 60

    d00br0,

    Did you get the above code to work? I’m hoping to do same with a version of Enterprise Pro, split the Home Top into 2 widget areas. Wanted to know if you got it working before I started with your code.

    Tks.
    -Kent


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: News Pro/Footer Sidebar Formatting #97712

    Kent
    Participant
    Post count: 60

    Tony,

    Fantastic. That worked like a charm. I think it wasn’t showing because I was in mucking around with it.

    -Kent


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: News Theme-Center Nav Menu #89844

    Kent
    Participant
    Post count: 60

    Aw man! I need to do same and can’t figure it out. Can one of you guys tell me what you did?

    -Kent


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Can't figure out menu float #88534

    Kent
    Participant
    Post count: 60

    Eric,

    I stand corrected. I had another line above it that was conflicting and when I took that out, it worked! Thanks!

    -Kent


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Can't figure out menu float #88531

    Kent
    Participant
    Post count: 60

    Eric,

    Thanks for that, but no, didn’t do it. It just transposed the two links.

    Before it said ‘Patient Login | Dental Referrals’ now says opposite. Hmmm.


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Slider Images Not Centered #87944

    Kent
    Participant
    Post count: 60

    Dave,

    Thanks, I figured it out but it’s been awhile so I don’t remember exactly what I did! Closing the post though.

    Cheers!


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Outreach Menu Broken #87943

    Kent
    Participant
    Post count: 60

    Thanks, Jen. That worked.

    -Kent


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Moving install borked the slider? #87942

    Kent
    Participant
    Post count: 60

    Andrea, that fixed the issue. Thanks.


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: AgentPress Listings, Different Theme #87941

    Kent
    Participant
    Post count: 60

    Thanks for the info folks, but project was scrapped! :)


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Remove Link Styling on Images in Sidebar #87940

    Kent
    Participant
    Post count: 60

    Hi everyone, FWIW, I wrote support and got this answer. It worked.

    “I would recommend creating a class to use when you don’t want a border. Add this to your style.css file.”

    .noborder {
          border: none;
    }

    Then, you can use that like this:

    <a class="noborder" href="#">stuff</a>


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: News Pro Sidebar on Left on Homepage #87939

    Kent
    Participant
    Post count: 60

    Nevermind. I figured it out. In case anyone else is wondering, just replace the force layout in your front-page.php with the one from here of your choice: http://my.studiopress.com/snippets/admin-management/#force-layout-settings


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Buttons in Modern Portfolio Theme #86639

    Kent
    Participant
    Post count: 60

    For some reason, I think that code on the setup page is wrong. I had the same issue. You have to change the class of the button:

    <div class="alignright"><a class="cta-button" href="your link here">Your Button Text</a></div>


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    in reply to: Remove Link Styling on Images in Sidebar #65667

    Kent
    Participant
    Post count: 60

    Dave,

    Thanks for that. When I put your code in, it does indeed nuke the underlines for my text links as well, which I don’t want.

    When I try this:

    .sidebar .textwidget a img {
      border-bottom: 0;
    }

    Nothing changes. I’m stumped.


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

    • This reply was modified 1 year ago by  Kent.
    • This reply was modified 1 year ago by  Kent.
    in reply to: Add Sidebar to Minimum Theme #63220

    Kent
    Participant
    Post count: 60

    Thanks for that, Anita. I ‘un-removed’ the other sidebar option, but there’s no sidebar alt in the CSS. I’ll dig around and see if I can scavenge some code from another theme.

    Would copying all the existing sidebar CSS and renaming it ‘sidebar-alt’ work? Maybe I’ll try that.


    Dad. Biker. Designer. | kentfackenthall.com | Circle me on Google+, and say hi so I can add you to my WordPress circle!

Viewing 15 posts - 1 through 15 (of 54 total)