Trisha

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • in reply to: Transparent Footer Credits #48945

    Trisha
    Participant
    Post count: 19

    To answer your questions:
    1) You would need to set your #footer background-color to #000033 –

    2) To set the width to entire width of the page you would need to set the classes within the .wrap to be width 100% or with float: clear;

    I hope this helps,


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Setting the width #48809

    Trisha
    Participant
    Post count: 19

    You need to create a child theme style sheet named style.css in a subdirectory of the theme that you want to modify. The art of blog has a great tutorial about how to create a child theme for Genesis which goes into more details.

    From there you can set the rule for your page width in your style.css file (just remember that people may be visiting your site on different devices, so test on as many as you can.)


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Help please: Displaying comments on blog page #48704

    Trisha
    Participant
    Post count: 19

    Hi Doug,

    It should work for you.

    You need to include it in your functions.php file.

    Firstly you will need a function in your functions file to initialize subsequent functions. In this case my function looked like this:

    <?php
    add_action(‘genesis_setup’,'child_theme_setup’,15);
    function child_theme_setup() {
    //extract from function child_theme_setup
    
    //Show comment form on posts without having to click through
    add_filter (‘genesis_after_post_content’, ‘be_show_comment_form’);
    }
    ?>

    Secondly, you need to create your be_show_comment_form function, which is the one that looks like:

    <?php function be_show_comments() {
    	global $withcomments; 
    	$withcomments = 1;
    	comments_template( ' ', true );
    }
    ?>

    I hope this helps, Doug post the URL when you are looking for some help – it may make easier for us to help you.

    Kind regards,


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Help please: Displaying comments on blog page #48081

    Trisha
    Participant
    Post count: 19

    Genesis > Theme Settings – Comments on Pages unchecked &
    Individual pages > Comments unchecked.

    Comments are only allowed on the blog page which is the guestbook.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Help please: Displaying comments on blog page #48004

    Trisha
    Participant
    Post count: 19

    I won’t wait next time :)

    With the way that the site has been configured (the home-page is a separate page that does not allow comments) so that it does not seem to be necessary, why do you think I need that?

    (Bearing in mind the blog home page is the guest book) ~ I ask to learn, not to argue.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Getting white back on the back drop #47990

    Trisha
    Participant
    Post count: 19

    Hi Alexander,

    When you changed your style in the theme settings you set the declaration (on your html at line 131) to be:

    body.custom-background {
    background-color: #eae1e1;
    }

    This set all of your theme’s body to the dark gray.

    To get those icons to have a like background you need to add this declaration to your CSS

    div.featuredpage{
    background-color: #fff !important; 
    /*Adding the !important declaration ensures that this rule won't be over-written*/
    }

    Looking at your source code you seem to have a lot of CSS and script files which will affect your load-time make sure that you install a good cache-ing plugin to mitigate this.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: CSS doesn't work on Localhost #47987

    Trisha
    Participant
    Post count: 19

    Hi MM,

    In your debugging mission I would consider opening the source of the two installs side by side and comparing the head section of the source. I am very surprised that it is with the database that is de-activating your CSS since that should generally be a feature of the functions (php) and not the database (mySQL).

    As Carrie says the wild adventurous world of troubleshooting.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Help please: Displaying comments on blog page #47986

    Trisha
    Participant
    Post count: 19

    Thanks Anita,

    I definitely think that post put me in the right direction (since it led me to viewing the code for single.php).

    The solution to get the comments to display is a ridiculously simple line of code (which took me over 10 hours worth of playing around before I eventually stopped being prideful and asked for help).

    <?php function be_show_comments() {
    	global $withcomments; 
    	$withcomments = 1;
    	comments_template( ' ', true );
    }
    ?>

    I simply needed to add the arguments to the call to comments_template.

    Note: for the purposes of this site I do want to keep the comment form.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Site Finished – Whatcha think? #47811

    Trisha
    Participant
    Post count: 19

    HI Amelia,

    The site looks great, I would just make the following changes:

    1. changing the genesis favicon to one using the Wezesha logo (The all-in-one favicon plugin makes it very easy)
    2. Use something other than just changing the text-colour on the navigation text to show when it is selected: e.g. making the text bold

    I just clicked through to the “Our Mission” page and the text is cut off on the right hand-side. It should be a simple fix by either setting:

    • max-width:
    • or

    • margin-right:

    under the #content div.

    I love the cause as well.

    P.S. I viewed the site using Firefox 21.0


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    • This reply was modified 1 year, 3 months ago by  Trisha. Reason: Noticed the our mission page text being clipped
    • This reply was modified 1 year, 3 months ago by  Trisha. Reason: Noticed the our mission page text being clipped
    in reply to: CSS doesn't work on Localhost #47810

    Trisha
    Participant
    Post count: 19

    This is a very strange thing.

    If you create a completely fresh WordPress site on your localhost does that CSS work? (Unfortunately I am trying to help you from XAMP – the Windows version of MAMP).

    Have you modified anything in the header.php of the theme?


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Make horizontal scroll when window is too narrow #47786

    Trisha
    Participant
    Post count: 19

    Hi Xammamax,

    The CSS property that you need to use is overflow with a value of auto (if you only want the scrollbars to appear when the content is bigger than the viewport or scroll if you want the scrollbars to always be visible.

    Generally I have not had problems with it but I believe it can be quite buggy if viewed through IE or opera.

    You can read up on the property on SitePoint’s excellent CSS reference.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Logo Image ? #47776

    Trisha
    Participant
    Post count: 19

    It’s a pleasure Kimberly. I have had that problem myself not so long ago.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: CSS doesn't work on Localhost #47774

    Trisha
    Participant
    Post count: 19

    So to be clear your html generated by WordPress is working it is only the CSS that is not working?

    When you view the source for your page does it display a link to the CSS at all?


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Introducing myself #47681

    Trisha
    Participant
    Post count: 19

    Thanks for the welcome David.


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

    in reply to: Logo Image ? #47665

    Trisha
    Participant
    Post count: 19

    Hi,

    I can’t comment on the Amped theme itself but maybe this will help:

    In the site’s dashboard under “Genesis” > Theme Settings >“Header” under “Use for site title/logo” select: “Image logo”.
    Image showing these options selecting.

    Using an FTP client (like FileZilla) or through your cPanel upload the logo to your themes images folder. The path will probably be something similar to:
    public_html > wp-content > themes > themename > images.

    You need to name your image file logo.png (there may already be a file with the name logo.png in this folder which you can overwrite or rename the existing file.)

    Hope this helps,
    Trisha


    I tweet as @trishawebs

    “Make New Mistakes. Make glorious, amazing mistakes. Make mistakes nobody’s ever made before.” ~ Neil Gaiman

Viewing 15 posts - 1 through 15 (of 16 total)