A Question About The Document Title Settings

Community Forums Forums General Discussion A Question About The Document Title Settings

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  cdils 1 year, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #46378

    Alex Taylor
    Participant
    Post count: 4

    Hi, hoping someone can help me with this, it’s driving me mad!

    The problem is that the document titles are often wrong when they show up in the Google search results. For example, I have a post with a title of “5 Simple Ways to Naturally Boost Your Serotonin.” When I look at the document title if I’m actually on my own website, that’s what the document title says.

    But when I look at the same page when it’s listed in the Google search results, it reads “5 Simple Ways to Naturally Boost Your Serotonin – Stop Panic Attacks.”

    Here’s the page from the above example: http://preventyourpanic.com/how-to-increase-serotonin-naturally

    And to see it in Google with the unwanted addition, just do a Google search for “how to increase serotonin” and it should be on page 1 or 2.

    No matter what I change in the settings, it keeps doing this. And it even does it on brand new posts even though I don’t have “Stop Panic Attacks” in any of the SEO settings. I think I had stop panic attacks there a long time ago, but not now. I believe this function is if you want your site name or something similar to appear after all post titles. But I don’t want anything there except the post name.

    I’m wondering if this is to do with some kind of clash with All In One SEO, which is a plugin I used to use. But it’s been deleted for a long time now.

    I’d really appreciate it if you could tell me how to fix this!

    #47070

    cdils
    Participant
    Post count: 421

    Hi Alex,

    Are you using any SEO plugin now or just the default SEO options that come with Genesis?

    Here’s a quick tutorial on setting up the SEO options (the standard ones in Genesis): http://www.bourncreative.com/genesis-seo-settings-guide

    Double-check that you’re set up correctly per the tutorial. If you’re still having problems, it’s possible that All In One left some tidbits behind in your database. Rule out the first and then we can explore other options if needed.

    Cheers,
    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly Genesis-focused podcast called Genesis Office Hours. I tweet @cdils.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.