Beautiful Pro Theme – Header Nav Position

Community Forums Forums Design Tips and Tricks Beautiful Pro Theme – Header Nav Position

This topic is: not resolved

This topic contains 15 replies, has 6 voices, and was last updated by  Alle McCloskey 9 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #74616

    weslinda
    Participant
    Post count: 193

    Good evening. So I rolled out Beautiful Pro on a site that I manage for a local group of Help-Portrait in Baltimore. I added the custom image, and setup the menu in the header. However, the menu position looks out of place. Does anyone know if this is a theme issue? It isn’t in the same location as it is on the demo. Does using the custom header image throw things off?


    Loving the Genesis Life!

    http://www.helpportraitbaltimore.org/
    #74618

    nutsandbolts
    Keymaster
    Post count: 3202

    It looks like your logo image has made the header area quite a bit taller than the demo – you can fix that and center the menu vertically by adding margin-top: 35px; to your stylesheet under .site-header .widget-area.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74621

    Erin Ulrich
    Participant
    Post count: 57

    (Andrea, I had my answer all ready, then realized you just beat me to it. So I’m just adding mine to what you’ve already stated. :)

    I’ve experienced the same issue when using a logo image of exactly what the theme calls for (320px x 120px). So it does seem to be a bit of an issue, but at least it’s an easy fix with adding the padding.

    On another random note, it’s fun to see a Help-Portrait site mentioned here. I do the website for the Allume Conference, and Help-Portrait was a sponsor this year. :)


    Erin Ulrich | Design by Insight | @erinulrich

    #74624

    weslinda
    Participant
    Post count: 193

    Thanks for the quick reply. My concern is that I’m following all of the theme’s instructions. I’m following the logo size that it recommends to use. I didn’t want to introduce my own CSS fix if this is a known issue.

    By adding that, then I need to pay attention to that amount throughout the responsiveness of the theme.

    I was more curious if this was standard results for the theme. If you look at my header side by side with the demo, you’ll see the menu on the demo is actually lower than the menu on my site. Thus my question on if there was something missing in the configuration to explain why mine wasn’t turning out the way the demo was.

    I’m quite comfortable on the CSS to fix this, I’m more interested in knowing if this is a known issue and how the theme responds when a customer header image is used. If it is, then in my opinion this is something that should be fixed in the root theme. I should not have to insert CSS when I’m following theme instructions.


    Loving the Genesis Life!

    #74625

    nutsandbolts
    Keymaster
    Post count: 3202

    I would suggest submitting a ticket to the official StudioPress support team. Since the forums are manned by volunteers, we aren’t in a position to do much about that, though I definitely see where you’re coming from.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74627

    weslinda
    Participant
    Post count: 193

    I have submitted a ticket to support. I asked the question here to see if others had seen the issue or if it was something off on my own configuration. Looks like at least 1 other person has seen this, so I’m curious to hear the response from StudioPress.


    Loving the Genesis Life!

    #74629

    nutsandbolts
    Keymaster
    Post count: 3202

    If you don’t mind, update this thread when you hear back from SP so other users might be able to find this in a forum search. Thanks!


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74631

    weslinda
    Participant
    Post count: 193

    Don’t mind at all. I’ve seen this in other themes as well. It’s just a bit frustrating that this hasn’t been polished 100%.


    Loving the Genesis Life!

    #74732

    weslinda
    Participant
    Post count: 193

    So in initial conversations, it appears that this is the way they did it. No real reason. Just the way the theme was designed. If you switch to not using a Header Image, then you get drastically more padding/margin built into the header right nav.

    Header Image: https://www.dropbox.com/s/hjxwpnxts0m2i0g/padding-spacing-demo-vs-real.png

    No Header Image: https://www.dropbox.com/s/f3rukcfglkaz9t9/No-Header-Image.png

    In my opinion, if you centered the text to the text, then why wouldn’t you center the text with the Header Image? The idea was something else in the designers mind. Doesn’t make sense to me as one would think it would line up.


    Loving the Genesis Life!

    #76775

    wendyinoc
    Participant
    Post count: 4

    I have an issue as well with the menu. Mine is going under my Logo or if I leave Text. I really want it to be the right like the picture . Help :)
    http://www.cruisebride.com

    #76776

    wendyinoc
    Participant
    Post count: 4

    Cancel solved the problem.

    #93573

    Brenda
    Participant
    Post count: 12

    O.K. – I”m reading through all of this, but I can’t seem to fix my problem. When I uploaded a header, the header is centered with the nav bar below. I want it to look just like the demo but using my own name/header in the top left – where “Beautiful Theme” is.

    #93575

    nutsandbolts
    Keymaster
    Post count: 3202

    Can you post a link to your site, Brenda? It’s always easier to help if we can see what you see.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #93610

    Brenda
    Participant
    Post count: 12

    Yes, it’s http://www.triplebraidedlife.com

    I had it in maintenance mode, but I’ll take it off to show you. Thank you!

    #93614

    Brenda
    Participant
    Post count: 12

    And I also don’t know why I’m seeing a gray bar above the site banner?

    I want to take out that bar and use the entire space above the banner for my logo/header and nav bar.

    Like this: http://www.brookemcglothlin.com/

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.