Blog posts not appearing on page

Community Forums Forums General Discussion Blog posts not appearing on page

This topic is: resolved

This topic contains 10 replies, has 2 voices, and was last updated by  AC 1 year, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #41841

    eamonmoriarty
    Participant
    Post count: 238

    Using Fabric8ted theme I am developing a website at http://www.calligraphy.ie.
    The home page is set to a static page and the blog page is set to “News” page. The problem is that none of the posts which I have created (just a few test posts) appear on the News page when using the Fabric8ted theme.

    If I change to the Genesis default theme or Twenty Twelve the posts appear.

    Any ideas how to fix this please?


    Eamon Moriarty
    EM Dzine

    #41846

    AC
    Blocked
    Post count: 7712

    On the News page, you need to select the “Blog” template for the blogs to show up. I also provide support for EightCrazy Designs, the developer of that theme. If you need more assistance on the Fabric8ted theme, please submit a ticket here on the EightCrazy support website – http://support.eightcrazydesigns.com/.

    Thank you and you’re doing a great job using the theme!

    #41906

    eamonmoriarty
    Participant
    Post count: 238

    Thanks for your reply and the effort to communicate via EightCrazy support website.

    The news page was already set to “Blog” template. I have since deleted the News page and created a new page with a new name and set that as the blog page but the result is the same – no posts appearing.

    Strangely, on the Edit page if I go to “Preview changes” the posts show up but when I go to “Wiew Page” – nothing!


    Eamon Moriarty
    EM Dzine

    #41912

    AC
    Blocked
    Post count: 7712

    I know someone else had this issue. Let me keep looking for you. I just have to remember what fixed it. I am not giving up on this! Go to bed….!!! {smile}

    #41913

    AC
    Blocked
    Post count: 7712

    What plugins do you have installed? Have you tried deactivating your plugins?

    #41914

    AC
    Blocked
    Post count: 7712

    Try changing your Permalinks to something other than what you have right now. And take a look. Go to Settings > Permalinks.

    #41916

    AC
    Blocked
    Post count: 7712

    Here’s something else also. Go to Genesis > Theme Settings. Scroll down to Blog Page Template – look for Number of Posts to Show. What number do you have in that box? If it’s 10, set it at 5 and tell me if they show up.

    #41919

    eamonmoriarty
    Participant
    Post count: 238

    I Had  permalinks set to /%postname%/. Now I tried the default but that didn’t w0rk.

    I had already changed the number of post sto show to 3 and now I tried 5 – not successful.

    I am now going to try disabling the plugins.


    Eamon Moriarty
    EM Dzine

    #41926

    AC
    Blocked
    Post count: 7712

    Did you follow Shannon’s instructions in the Tutorial for the Content Archives?

    http://fabric8ted.eightcrazydesigns.com/tutorials/1283-2/

    #41987

    eamonmoriarty
    Participant
    Post count: 238

    Anita

    Thanks for your help in this matter.

    Although the problem was not caused by any of the above, you prompted me to check all the plugins and widgets thoroughly.

    I found that, during the early experimental phase, I had placed a text widget in the Home – Call to Action sidebar which didn’t work but I left it there and forgot about it.

    Now when I removed this text widget the posts are back on the News page! Why this should be the case I don’t know but it works. So, problem solved without knowing why.


    Eamon Moriarty
    EM Dzine

    #42011

    AC
    Blocked
    Post count: 7712

    Aaah Haaa! See the home page works like this – if you don’t want to use the home page layout – do not drag anything in a widget area for the home page. Once you put something in a home page widget area – the theme assumes you want to use the home page. If you don’t want to use the home page, leave home page widgets empty and it will default to the blog page. This is why I like to do Join.me so I can get a visual of what you have going on. I look at all that stuff.

    Since this is resolved now, I will close this thread.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Blog posts not appearing on page’ is closed to new replies.