Executive Pro Theme Header Image Size

Community Forums Forums General Discussion Executive Pro Theme Header Image Size

This topic is: not resolved

This topic contains 6 replies, has 3 voices, and was last updated by  rcwatson 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #72640

    ChrissyJee
    Participant
    Post count: 4

    My site is: evilpowdercoating.com

    I am using the executive pro theme and trying to user a header image size of 520×100. I made updates to the CSS to fit the image but it is pushing my navigation links and slider down. Any thoughts to what is causing this?

    http://evilpowdercoating.com
    #72654

    braddalton
    Participant
    Post count: 8857

    You can change the PHP code in your child themes functions.php file to this:
    [php]
    //* Add support for custom header
    add_theme_support( ‘custom-header’, array(
    ‘width’ => 530,
    ‘height’ => 100,
    ‘header-selector’ => ‘.site-title a’,
    ‘header-text’ => false
    ) );
    [/php]

    And then change the CSS code in your style sheet:
    [css]
    .title-area {
    font-weight: 700;
    float: left;
    overflow: hidden;
    width: 530px;
    }
    [/css]

    Or add this to your style sheet.
    [css]
    .site-header {
    background-image: url(images/logo.png);
    width: 530px;
    height: 100px;
    float: left;
    }
    [/css]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #72873

    ChrissyJee
    Participant
    Post count: 4

    Hi Brad! I’m so glad you responded. I think you are awesome!

    I did all of the above and everything looks great except I lost the navigation I had on the top right. Any ideas what’s going on?

    #72905

    braddalton
    Participant
    Post count: 8857

    You won’t lose it if you use the CSS code above to add your logo.

    You would also reduce trhe width for the header right widget to compensate for the increase in width.
    [css]
    .site-header {
    background-image: url(images/logo.png);
    width: 530px;
    height: 100px;
    float: left;
    }

    .site-header .widget-area {
    float: right;
    width: 610px;
    }
    [/css]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #73060

    ChrissyJee
    Participant
    Post count: 4

    I’ve added the CSS code and the code to reduce the width of the right header widget and the nav is still pushed to the next line.

    You can see it here:

    http://evilpowdercoating.com/2012/10/01/threaded-comments/

    Any thoughts?

    #73065

    braddalton
    Participant
    Post count: 8857

    Not sure sorry.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #80705

    rcwatson
    Member
    Post count: 18

    Hi. I’m having this same problem, except when I upload my image, it wants to crop it to the default size that comes with the template (200×100 or something).

    To match the height and width of my customer’s logo, I modified the following code in my functions.php to what you see below

    //* Add support for custom header
    add_theme_support( 'custom-header', array(
        'width'           => 200,
        'height'          => 139,
        'header-selector' => '.site-title a',
        'header-text'     => false
    ) );

    but I haven’t done any other CSS changes. I just need the logo to default crop to 200×139, not that 200×100 size that it wants to do by default.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.