Featured Posts Widget Not Ordering

Community Forums Forums Design Tips and Tricks Featured Posts Widget Not Ordering

This topic is: resolved

This topic contains 4 replies, has 2 voices, and was last updated by  AC 1 year ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #58921

    AC
    Blocked
    Post count: 7712

    I am using the Mocha Child Theme that I modified and in that modification I have added the Portfolio template from the Balance Child Theme. The template uses a Portfolio sidebar and I use the Featured Posts Widget to pull my category. It’s working fine except – it will not switch to the correct order. I have it set to display based on the ID and yet… it won’t order. Even when changing the order to one of the other options, it’s not ordering properly. Any ideas what could be causing this? The portfolio page is here. The newest entry is “Youth Day Event” and it should be the 1st one, not the third one.

    #59847

    Sridhar Katakam
    Participant
    Post count: 1017

    I re-created your set up on my test site running on localhost and don’t get the problem.

    The posts appear in the correct order with the latest at the left.

    Portfolio page:

    Portfolio page

    List of Posts:

    List of Posts

    Widget settings:

    Widget settings

    Do you perhaps have a plugin like Post Types Order that is causing the problem? Have you tried deactivating all plugins?


    #59877

    AC
    Blocked
    Post count: 7712

    Oh I really appreciate you taking the time to do all that!!! Thank you! No, I just changed it to Date and it’s still not showing up in the correct order. I am not sure why it works for you and not me :(. But something came to mind so I went to this in my CSS. I had “right” in there and not “left”. When I switch it – they are now in order, however, it’s not wrapping properly. Take a look at the page again.

    .page-template-page_portfolio-php .featuredpage .page, .page-template-page_portfolio-php .featuredpost .post {
    float: left;
    margin: 0 10px 10px 30px;
    overflow: hidden;
    padding: 0 6px 20px;
    width: 300px;
    }

    #59882

    Sridhar Katakam
    Participant
    Post count: 1017

    Add this to that selector:

    min-height: 280px;


    #59885

    AC
    Blocked
    Post count: 7712

    Oh! That fixed it! Thank you so much. It seems the past two days I’ve had an issue with “heights”. I need to learn more about them.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Featured Posts Widget Not Ordering’ is closed to new replies.