Focus theme – read more link

Community Forums Forums General Discussion Focus theme – read more link

This topic is: not resolved

This topic contains 6 replies, has 3 voices, and was last updated by  hawaiiguy 1 year, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #44469

    Lise
    Participant
    Post count: 15

    Hi anyone,

    I have installed and customized the focus theme on a client’s site and on this page, which is the category in the menu, http://destinationweddingdetails.com/category/real-destination-weddings  we need the ‘read more link’ within the [...]

    I don’t know how to make it happen.  The following is already in the functions.php

    /** Modify the WordPress read more link */
    add_filter( ‘the_content_more_link’, ‘custom_read_more_link’ );
    function custom_read_more_link() {
    return ‘<a class=”more-link” href=”‘ . get_permalink() . ‘”>Read More</a>’;
    }

    Thanks in advance

    Lise

    #44495

    rfmeier
    Participant
    Post count: 597

    Hello,

    Try using the WordPress ‘excerpt_more’ filter.

    [php]
    /* functions.php */
    function new_excerpt_more( $more ) {
    return ‘ <a class="read-more" href="’. get_permalink( get_the_ID() ) . ‘">Read More</a>’;
    }
    add_filter( ‘excerpt_more’, ‘new_excerpt_more’ );[/php]

    The above was pulled from the WordPress documentation. http://codex.wordpress.org/Function_Reference/the_excerpt

    I hope this helps.


    #44530

    Lise
    Participant
    Post count: 15

    Thanks Ryan, I will try.  I was under the impression that it would be in genesis, so I didn’t go look in the codex.

    Thanks again

    Lise

     

    #44536

    Lise
    Participant
    Post count: 15

    Actually Ryan, I fixed it another way…I was going to copy the code you gave me in my evernote, and that’s where I noticed I had already something relating to that.

    “To make sure that the category pages listing each post has the Read More link, go to genesis settings, content archives, set to “display post content’ and then set the limit of charaters to 300 and it will show up.”

    And it works!

    Have a nice weekend

    Lise

    #44537

    rfmeier
    Participant
    Post count: 597

    Awesome. Glad you found a solution!


    #44542

    Lise
    Participant
    Post count: 15

    Thanks for your help Ryan

    Lise

    #48620

    hawaiiguy
    Participant
    Post count: 10
    This reply has been marked as private.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.