Footers Overlap

Community Forums Forums Design Tips and Tricks Footers Overlap

This topic is: resolved

This topic contains 7 replies, has 4 voices, and was last updated by  Chris Cree 1 year, 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8092

    CornerstoneKat
    Participant
    Post count: 40

    I am a new Prose user and trying to add text to my footer widgets.  I am getting very frustrated because footer widget 2 appears to overlap footer widget 3 making all of footer widget 3′s content drop to below where footer widget 2′s content ends.  Is there a solution to solve this?  I’ve tried adjusting each footer widget’s width in the CSS but there’s no response.  You can see it here.

    #8099

    Chris Cree
    Participant
    Post count: 147

    It’s a width & margin issue. You can change the first one to this:
    [css].footer-widgets-1 {
    float: left;
    margin: 0 10px 0 0;
    width: 275px;
    }[/css]

    and then change the width of the .footer-widgets-2 and .footer-widgets-3 to 275px also and then they should fit.


    #8132

    CornerstoneKat
    Participant
    Post count: 40

    I did that.  No change.  It’s like the theme is not responding to any code changes I make.  Any other ideas?

    #8180

    Jared Williams
    Participant
    Post count: 47

    Where are you making the changes? It’s pulling your minified.css


    #8201

    Chris Cree
    Participant
    Post count: 147

    Yeah. Deselect CSS minification while you are making modifications. From your WP dashboard go to Genesis –> Design Settings and scroll to the bottom where you see “General Settings”. Uncheck the “Minify CSS?” box and click “Save Settings”

    Then when your site is done and customized the way you want it you can re-check that box.

    I also recommend you turn off the “copyprotect” plugin while you are customizing things. It’s triggering strange behavior on your site that might be making it harder to see your changes.

    You’re also going to want to turn off W3 Total Cache until you are done customizing your site. If your site is caching things it will keep your customizations from showing up.


    #8202

    Anita
    Participant
    Post count: 7568

    Change Footer Widget 1 to this:

    .footer-widgets-1 {
    float: left;
    margin: 0 10px 0 0;
    width: 275px;
    }

    Change Footer Widget 2 to this:

    .footer-widgets-1 {
    float: left;
    margin: 0 10px 0 0;
    width: 275px;
    }

    Change Footer Widget 3 to this:

    .footer-widgets-3 {
    float: right;
    margin: 0;
    width: 275px;
    }

    I changed it in Firebug and they are all straightened out now.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #8208

    CornerstoneKat
    Participant
    Post count: 40

    Chris, that solved it.  Weird.  Now maybe I can make some others changes I’ve been trying to do too.  Thank you!  Oh and thank you Anitac for the code, just in case.  It is the correct code (the exact ones I had already tried in fact).  Thanks.

    #8210

    Chris Cree
    Participant
    Post count: 147

    Can’t tell you how many times I’ve gone in to make a CSS change and not seen it behave the way I expected because W3 Total Cache was enabled. Always disable caching when you are making changes. Or it will drive you bug nuts.

    It’s good to turn off other plugins that affect the presentation too, which is why I recommended disabling the copy protection plugin.


Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Footers Overlap’ is closed to new replies.