Genesis 2.0.1 Upgrade Changed my Header?

Community Forums Forums Design Tips and Tricks Genesis 2.0.1 Upgrade Changed my Header?

This topic is: not resolved

Tagged: ,

This topic contains 8 replies, has 3 voices, and was last updated by  G3Tech 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #74115

    tpaulwhite
    Participant
    Post count: 23

    Hi – I just upgrade to Genesis 2.0.1 using the News theme. When I did this, it changed the background of my header

    You will notice that the red subnav bar maintained it’s size, width and color – the only that that change was a ” “/v ” above it – not sure where this came from?

    Also – the header had a full width white background that disappeared when I upgraded to Genesis 2.0.1 – it the same width as the red subnav bar, just below it. Now it has the same background as the wrap. I would like it to return to a full width, white background.

    Can you please help me fix these two issues – they are directly related to the upgrade to Genesis 2.0.1 – I had put some code at the bottom of my style sheet to make the full width, so you may find some that conflicts there.

    I really appreciate the help!

    Site – http://www.xohawaii.com

    http://www.xohawaii.com
    #74134

    nutsandbolts
    Moderator
    Post count: 3131

    The random text is coming from your All in One Webmaster plugin – the Google site verification code has an extra " /> at the end.

    To fix your header, remove the header image from Appearance > Header and add the following to your stylesheet:

    #header {
    background: #ffffff url(http://xohawaii.com/wp-content/themes/news/images/header.png) no-repeat !important;
    

    Let me know if that doesn’t fix the problem.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74161

    tpaulwhite
    Participant
    Post count: 23

    Thank you – I followed your instructions. I had to disable All in One Webmaster because teh “/> appeared to be hardcoded and I could not change it. Any ideas here in case I want to use it again later?

    The header issue was partially fixed – it definitely returned my full width white space, but it added the site title and tagline on top of my header image. Can you please tell me how to address this?

    I really appreciate your help!

    #74169

    tpaulwhite
    Participant
    Post count: 23

    Thank you – I followed your instructions. I had to disable All in One Webmaster because teh “/> appeared to be hardcoded and I could not change it. Any ideas here in case I want to use it again later?

    The header issue was partially fixed – it definitely returned my full width white space, but it added the site title and tagline on top of my header image. Can you please tell me how to address this?

    I really appreciate your help!

    You can look at the site to see the issue http://www.xohawaii.com

    #74183

    nutsandbolts
    Moderator
    Post count: 3131

    Okay, stay with me here. There are a couple of steps to get rid of the text but I promise they aren’t hard. :)

    In functions.php, remove the custom header function. It should look like this:

    /** Add support for custom header */
    add_theme_support( 'genesis-custom-header', array( 
    	'width'	=> 960, 
    	'height'	=> 110 
    ) );

    That will take away the option for Appearance > Header.

    Then go into your Genesis theme settings and you should have a new dropdown to choose either dynamic text or image logo. Pick image logo and save your settings; the text title and description should go away. If they don’t, let me know.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74344

    tpaulwhite
    Participant
    Post count: 23

    That fixed it – Thank you Andrea!

    #74677

    G3Tech
    Member
    Post count: 2

    Me Too! After my upgrade to Genesis 2.01 the header color changed from #9BB449 to white. I have a basic understanding of CSS and PHP but this is deeper than I get. The site I’m working on is Freddiebell.com. I can see that the theme was created by adding additional CSS lines to the http://freddiebell.com/wp-content/themes/FreddieBell/style.css?ver=2.0.1 file. This is a Firebug screenshot which gave me that path: http://screencast.com/t/Cz6StyrIbZj6. In the CSS window it shows 3 statements around the header format. If I disable the second one the green comes back. But the path for the second line is just freddiebell.com #2 and I don’t understand where that comes from.

    Hope it’s something simple!
    Thanks

    #74808

    nutsandbolts
    Moderator
    Post count: 3131

    In your case, you can return the green to your header by doing the following:

    (1) Remove your header image under Appearance > Header.

    (2) Add this to your stylesheet:

    #header {
    background: ##9bb449 url(http://freddiebell.com/wp-content/themes/FreddieBell/images/header.png) no-repeat !important;
    }

    Let me know if that doesn’t work.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74906

    G3Tech
    Member
    Post count: 2

    I was thinking I had to go find it elsewhere in the stylesheet. Didn’t think about just tacking that onto the end. Thanks Andrea that worked fine!

    Gregg

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.