Genesis 2.1.0 Duplicates After Entry Widget Content

Community Forums Forums General Discussion Genesis 2.1.0 Duplicates After Entry Widget Content

This topic is: not resolved

Tagged: 

This topic contains 19 replies, has 12 voices, and was last updated by  SavvyJackie 5 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #112225

    GlenF
    Member
    Post count: 1

    I’m using the Magazine Pro theme and after upgrading to Genesis 2.1.0 any widget in the After Entry area is duplicated on my posts. I rolled back Genesis and the problem went away.

    I see from the release notes this suspect piece was part of the update:

    “Added new widget area with genesis-after-entry-widget-area theme support.”

    http://itconcierge.co
    #112259

    jandabt
    Member
    Post count: 1

    Hi. I have the same problem in metro pro child theme.
    I haven’t detect another isssue by the moment.

    Thanks.

    #112305

    SavvyJackie
    Participant
    Post count: 94

    Same problem in the Eleven 40 Pro Theme. Seems like it is doubling it. When adding one widget – it shows before Author Box and one more shows after.

    #112310

    scottros
    Member
    Post count: 1

    I have the same problem with Wintersong Pro.

    Seems like it’s something related to Genesis 2.1 rather than any individual theme, if we all have the problem?

    #112311

    tafita
    Participant
    Post count: 33

    Yep same here for the agency pro theme, it’s registering the after entry widget twice.

    Anyone got a solution, there was a recent upgrade to Genesis so reversion to the previous version might work although I have not tried that

    http://invocationofficial.com/our-work/check-out-our-new-website/

    #112332

    genwrock
    Member
    Post count: 935

    @SavvyJackie & Other Eleven Pro Theme User:

    There have this code in your functions.php file:

    add_action( 'genesis_after_entry', 'reposition_post_page_dates', 5 );

    disable the code once and check the site again:

    //add_action( 'genesis_after_entry', 'reposition_post_page_dates', 5 );

    // will disable the code.


    See My PRO Genesis Child Themes | Need Genesis Developer? | Follow Me on Twitter

    #112344

    Intently Digital
    Member
    Post count: 8

    Disabling that line of code worked for me using Sixteen Nine, thank you!

    #112351

    darren_c
    Member
    Post count: 4

    Thanks for the fix.
    Works on Agency Pro and Sixteen Nine pro

    #112366

    SavvyJackie
    Participant
    Post count: 94

    Thank you. That worked for me, however the code looked a litte different.
    I commented out this line in my functions.php for the Eleven 40 Pro theme

    add_action( 'genesis_after_entry', 'eleven40_after_entry', 5 );
    
    #112393

    Bart van Maanen
    Participant
    Post count: 30

    Thanks Savvyjackie, That fix worked for Sixteen Nine (after clearing cache too).

    #112394

    SavvyJackie
    Participant
    Post count: 94

    You’re welcome – it was genwrock’s suggestion that led to my solution.

    #112396

    SkintDad
    Member
    Post count: 5

    Hi, I’m having the same problem but I am running the Metro-Pro theme. Does anyone have a fix for this?

    Thanks is advance.

    #112399

    Bart van Maanen
    Participant
    Post count: 30
    #112401

    SkintDad
    Member
    Post count: 5

    Hi Bart, thanks but I do not have that line of code in my theme?

    #112404

    Bart van Maanen
    Participant
    Post count: 30

    @ SkintDad: I think it’s called somewhat different in the Metro Pro theme. Look for this section:

    //* Hooks after-entry widget area to single posts
    add_action( 'genesis_entry_footer', 'metro_after_post'  ); 
    function metro_after_post() {
    
        if ( ! is_singular( 'post' ) )
        	return;
    
        genesis_widget_area( 'after-entry', array(
    		'before' => '<div class="after-entry widget-area"><div class="wrap">',
    		'after'  => '</div></div>',
        ) );
    
    }
Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.