Genesis Grid Loop Woes – No Thumbanils

Community Forums Forums Design Tips and Tricks Genesis Grid Loop Woes – No Thumbanils

This topic is: not resolved

This topic contains 8 replies, has 2 voices, and was last updated by  AC 1 year, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #46113

    sstiavetti
    Participant
    Post count: 11

    I’ve been fighting with the Genesis Grid Loop plugin for weeks now and no matter how I try, I can’t get the images to show up. I was able to remove the byline details and all the other extraneous information I didn’t want to show up in the archives, but the photos disappeared too. The directive that removes the byline, etc, also takes out the photos.

    Here’s the staging server, with the plugin installed:

    http://staging.bendejes.us/category/savory/

    You’ll see the grid looks good, as do the titles. But the thumbnails just aren’t cooperating. I’ve regenerated them and gone through and made sure the first six or so posts in the savory category have featured images set, and still no dice. Sigh.

    Any ideas on what might be the problem?

    Here’s the css I’m using:
    `/* Genesis Grid Loop Styling ———– */

    .archive .teaser {
    height: 150px;
    }

    .teaser .entry-content,
    .teaser .post-info,
    .teaser .post-meta {
    display: none;
    visibility: hidden;
    }

    .archive .post,
    .search .post,
    .tag .post {
    margin-bottom: 20px;
    }

    .archive .teaser h2,
    .archive .teaser h2 a {
    font-size: 16px;
    height: 62px;
    text-align: center;
    }

    .teaser .post-image {
    display: inline;
    margin: 0 24px 5px 0;
    }`


    • This topic was modified 1 year, 3 months ago by  sstiavetti.
    • This topic was modified 1 year, 3 months ago by  sstiavetti.
    • This topic was modified 1 year, 3 months ago by  sstiavetti.
    • This topic was modified 1 year, 3 months ago by  sstiavetti.
    http://staging.bendejes.us/category/savory/
    #46116

    AC
    Blocked
    Post count: 7712

    You are using the Innov8tive child theme by Eight Crazy Designs. I provide support for Shannon who developed the theme. You need to remove this code from your functions.php file since you are not using the theme as she originally intended:

    [php]/** Remove the archive thumbnail from the blog page */
    add_action( ‘genesis_before_content’, ‘innov8tive_conditional_actions’ );
    function innov8tive_conditional_actions() {
    if( is_page_template( ‘page_blog.php’ ) && ‘full’ == genesis_get_option( ‘content_archive’ ) )
    remove_action( ‘genesis_post_content’, ‘genesis_do_post_image’ );
    }
    [/php]

    • This reply was modified 1 year, 3 months ago by  AC.
    • This reply was modified 1 year, 3 months ago by  AC.
    #46118

    AC
    Blocked
    Post count: 7712

    I take that back… it’s not Innov8tive but it sure looks like it, so disregard my instructions above.

    #46120

    sstiavetti
    Participant
    Post count: 11

    Hi Anita, what exactly does that code do? Is that what’s causing the plugin to not work?


    #46122

    AC
    Blocked
    Post count: 7712

    What is the initial child theme you started out with since I see it say Custom in the CSS. I thought you were using the Innov8tive Child Theme because it looks similar to it. If you were using that theme – you would have to remove that code from the theme and then the images would show up.

    #46127

    sstiavetti
    Participant
    Post count: 11

    I’m not sure, I didn’t design it. A friend did it for me.

    So does that code you listed above not exist with my functions.php? Then is there any idea on what might be causing these images to not show up in the Genesis Grid plugin?


    #46130

    AC
    Blocked
    Post count: 7712

    I don’t know if it exists or not. You have to open up the file and look. Look for either that or anything that with remove action. But I cannot say for sure.

    Go to Genesis > Theme Settings > Content Archives and is the box checked to Include Featured Image? If not, check that box and then let me know if they show up.

    #46144

    sstiavetti
    Participant
    Post count: 11

    Doh, Include Featured Image was off. I turned it on but still no dice. Good tip, though! Thanks!

    Anything else that might hinder thumbnails showing?

    What does the remove action code do? I’ll dig and see what I can find, but I’d like to know what it does before I remove it.


    #46195

    AC
    Blocked
    Post count: 7712

    It would remove a particular function. What I would suggest now is to go to the plugin Support area and post your issue there. They might know better how to fix it.

    http://wordpress.org/support/plugin/genesis-grid-loop

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.