Genesis Responsive Slider: How can I exclude slider category from blog page?

Community Forums Forums Design Tips and Tricks Genesis Responsive Slider: How can I exclude slider category from blog page?

This topic is: not resolved

This topic contains 7 replies, has 4 voices, and was last updated by  braddalton 4 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #104981

    pcgs51
    Participant
    Post count: 28

    I am working with Outlook Pro and the Genesis Responsive Slider. The slider plugin is built by adding slides to a post’s featured image. This slider works fine but I am only using the slider as a slider and I don’t need it to link to an article or anything. I don’t want these “slider” posts showing up on my blog page.

    http://fitnesshalloffame.com/blog/

    My site is using static pages pointing to a home page and a page called blog for my blog posts.

    I’ve tried everything I can think of to remove them. How can I exclude them from my list of posts? I tried using the exclude feature in the Genesis settings but have to believe that is for something else because I still see the slider category posts in my list of posts.

    Thanks


    Thanks,
    pcgs51

    http://fitnesshalloffame.com/blog/
    #104984

    nerdworker
    Member
    Post count: 46

    Hello pcgs51,

    That should be exactly what the exclude feature is for. Are you sure you used the category ID and not the name? Try viewing this video example — the first half should be what you need where she talks about excluding the category:

    http://thewpchick.com/studiopress-quick-tip-3-excluding-categories-on-your-blog-page/

    I hope that helps.

    Stefanie
    nerdworker.com

    #104988

    pcgs51
    Participant
    Post count: 28

    Thanks nerdworker,

    Too funny, that is exactly the video I’m watching. Wondering why my settings aren’t working. My category ID is 2. Like so:

    http://fitnesshalloffame.com/wp-admin/edit-tags.php?action=edit&taxonomy=category&tag_ID=2&post_type=post

    So I just type the number 2 into the box yes?
    I also tried selecting only one category for the blog page but all of the categories show up.

    I was wondering if this only works for non static pages but the video sure looks like her site is a static page scenario. What could be preventing this from excluding what I want?


    Thanks,
    pcgs51

    #104990

    pcgs51
    Participant
    Post count: 28

    Well, I Googled a little more and while I do think that the Genesis settings should have worked, I did find a way to remove this category here: http://nataliegraham.me/how-to-exclude-a-category-from-your-main-blog-feed/

    I opted for door #2 which was adding this to my functions.php. The “2″ indicating my category that I wanted to remove.

    function excludeCat($query) {
      if ( $query->is_home ) {
        $query->set('cat', '-2');
      }
      return $query;
    }
    add_filter('pre_get_posts', 'excludeCat');
    ?>

    I do wish the Genesis settings would have worked. They should have. Thanks for being there. Sometimes it really helps when you know others are out there pulling for you. Thanks nerdworker!


    Thanks,
    pcgs51

    #104992

    nerdworker
    Member
    Post count: 46

    I was just about to point you to that exact post, but you beat me to it! LOL

    I’m glad you got it. :)

    #111584

    kathiemt
    Participant
    Post count: 120

    I want to know what the video showed or did as I can’t get it to play. Is there a text step-by-step somewhere that explains please?


    Virtual Assistant & Nature Photographer
    Kathie Thomas: VADirectoryClick here for Australian images

    #111585

    kathiemt
    Participant
    Post count: 120

    Actually I worked it out, just with the description she has above the video. Worked a treat!


    Virtual Assistant & Nature Photographer
    Kathie Thomas: VADirectoryClick here for Australian images

    #111597

    braddalton
    Participant
    Post count: 10350
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.