Genesis Responsive Slider – URGENT

Community Forums Forums Design Tips and Tricks Genesis Responsive Slider – URGENT

This topic is: not resolved

This topic contains 7 replies, has 2 voices, and was last updated by  tekgirl02 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #20453

    tekgirl02
    Participant
    Post count: 31

    I need to get my project finished and cannot seem to the slider finished correctly/

    Can someone please tell me how to get the white box around the images on the home page in the slider removed or how to center the image within the white box…ideally, I would like the padding on the right to be the same as on the left.

     

    Thank you!

    #20454

    Bill Murray
    Participant
    Post count: 575

    1) Visit your Genesis->Slider Settings and set the max width = to the max width of your theme (1100 is just a very quick guess)
    2) Use a plugin like Ajax Thumbnail Rebuild to regenerate your thumbnails
    3) Use firebug so you can explore your page HTML


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #20458

    tekgirl02
    Participant
    Post count: 31

    Thanks, but I have done all of this…this is a home widget I created as there was none for the genesis slider (Mocha Theme), below the menu. I cannot seem to tweak the code or CSS to get this to display properly…

    #20462

    Bill Murray
    Participant
    Post count: 575

    Your home-slider ID is 1140px wide. Your slider is outputting images that are 920 x 400 px. That is controlled by the issues in my previous post.

    What is the current max width of your slider? (see my previous post for where this setting is)

    If you’ve followed the steps I listed, my suggestion is to take another look at them and follow them again. Pay careful attention to the order of the steps. The thumbnails for the slider are only built after you specify the slider max width. I don’t think there’s any code or CSS for you to tweak. The slider includes its own CSS, which you can override, but that’s not the source of your problem.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #20464

    tekgirl02
    Participant
    Post count: 31

    OK, so I set the max width to 1140 and yes, the max width was 940…

     

    Let me rebuild the thumbnails again and see what happens…thanks for the quick reply.

    #20466

    tekgirl02
    Participant
    Post count: 31

    Looks like what I really have to do is make the images 1140 wide…my objective really was to have a slider below the menu but only over the content, not taking up the entire theme width…

     

    Thank you…now at least I realize what I have to do…I have been spinning my wheels for hours…

    #20469

    Bill Murray
    Participant
    Post count: 575

    Whoa…

    You can have what you want. The important takeaway from this is that your issue (the slides not filling the slider) is controlled by 2 things: your slider settings and making sure that your images match that size (which you can use a thumbnail rebuild plugin to fix).

    If you want a narrower slider, you simply style your home-slider ID (presumably the 1 you created for the widget area). Let’s say that width is the width of your primary content (600px). You would then set your slider settings for that narrower area, get your image sizes right, and you’ll be fine.

    At the beginning, you had a slider in an ID that was full width and were wondering why the images weren’t filling it. Now that you know how to make images fill the slider, you can adjust the width of your widget area to suit your needs and then make the slider images work. Also, don’t forget to adjust the media queries at the bottom of your child theme’s style sheet to take into account the new widget area you added; otherwise, that content won’t be mobile responsive.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #20471

    tekgirl02
    Participant
    Post count: 31

    Thanks Bill! I totally understand now and will decide if I want the images to be full width or narrower…your post was very, very helpful!!!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.