Google Authorship Change with Genesis 2.0.2

Community Forums Forums General Discussion Google Authorship Change with Genesis 2.0.2

This topic is: not resolved

This topic contains 10 replies, has 5 voices, and was last updated by  doire 7 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #87092

    shytleh
    Participant
    Post count: 5

    I’ve tracked a problem that has cropped up with our Google authorship to a change that occurs with the upgrade to Genesis v2.0.2.

    I notice in the change log (http://genesischangelog.com/2.0.2, very helpful document, btw), you’ve described one of the changes as “Improved rel=author output to only target posts”.

    That’s a HUGE negative for many of our sites because (a) we want authorship to work for the homepage and all pages, and (b) we’re using IDXBroker, and since IDXBroker uses a page on our site as the template into which it populates MLS listings, the hundreds of listings pages that used to show up in the SERPS with authorship (and thus higher click through) now don’t have authorship.

    One such site is http://www.richmondvamls.net
    - Homepage – authorship not working
    - Post – authorship working: http://www.richmondvamls.net/did-you-just-hire-a-realtor-an-agent-or-a-salesperson
    - Listing page – authorship not working: http://listings.richmondvamls.net/i/12208/Richmond_VA_Foreclosures

    Questions:
    (1) Why do you consider it an improvement to only target rel=author at posts?
    (2) Can it be made a toggle so that it doesn’t hurt me (and I assume others) so badly?

    Thanks in advance, Hugh

    http://www.richmondvamls.net
    #87106

    AC
    Blocked
    Post count: 7712

    I saw the title to this and also want you to see this information just in case you haven’t. Read that, it’s pretty interesting and actually quite true. So if you see a reduction in your ranking, etc., this article should explain to you why.

    #87107

    shytleh
    Participant
    Post count: 5

    Thanks, that’s an interesting read.

    The article describes how/when Google decides to display authorship details. My question for the devs is more about why Genesis no longer even includes authorship details in pages. There’s obviously nothing we can do to influence Google, but it would seem that we should be putting our best foot forward and at least telling Google who authors a page.

    #87109

    AC
    Blocked
    Post count: 7712

    Well, as a backup – I added this to my Header Script under Genesis > Theme Settings -

    <link rel="author" href="https://plus.google.com/u/0/YOUR-NUMBER-HERE/posts">

    When I reveal source it’s on every page. So maybe add yours in there too.

    #87152

    workky
    Participant
    Post count: 76

    Google authorship has taken a hit all the way around!!! I like what you described anitac, never tried that. But I do have authorship markup on all my post and my authorship tag has gone bye bye.

    You should be able to assign authors on every post and page, for your home page you can enter it in manually or use Yoast SEO plugin, that’s they way I do it


    life’s tough, its a lot tougher if your stupid

    #87815

    shytleh
    Participant
    Post count: 5

    I was hoping one of the developers would chime in as it seems silly to require this work around.

    Nevertheless, thanks anitac as your fix works for me!

    #94528

    doire
    Participant
    Post count: 3

    I’ve followed the instruction in this article by Brian Gardner: http://www.copyblogger.com/wordpress-google-authorship/ but it didn’t work for me.

    I added the code snippet to my header and this has added a Google+ author link to all pages on my site, but it’s a stop-gap measure. I want to be able to have separate authors for each post. How do disable the link to the (non-existent) author page on my site?

    I’m using the Foodie theme, on the latest version of WordPress, but when you click on the author name at http://www.susandeans.com, it returns a 404.

    #94541

    Summer
    Participant
    Post count: 1105

    I thought Google was dropping authorship in favor of publisher in order to prevent author/spam/abuse of authorship service that had cropped up over the past year or so? If not dropping, then actively culling…

    If the author has an account, in Genesis 2.0, then there’s a Google+ field in their user profile… when that’s filled in, the rel=author is supposed to show up correctly, in addition to the rel=publisher that you can add in the Genesis SEO settings.


    #94547

    doire
    Participant
    Post count: 3

    Google is still actively promoting authorship, so I can’t comment on its impending demise. But, I have added the user profile to the Google+ field, but the rel=author field is not updating, it’s linking to a non existent /author/User Name page.

    #94582

    Summer
    Participant
    Post count: 1105

    The Google+ authorship link doesn’t have anything to do with the link to the WordPress author page. If the username archive page is missing, there’s something else wrong.

    Are you using Simple Edits or Simple Hooks to change anything? Did you do anything special with the permalinks, or try deactivating plugins to see if any of them might be interfering with your permalinks?


    #94595

    doire
    Participant
    Post count: 3

    Thanks for your help.

    Disabling permalinks allows me to see a list of all posts when I click on the author’s name, so there is a problem with the permalink to “/author/nicename”

    But, my biggest problem is the Google+ authorship. Disabling all plugins doesn’t fix this, activating the default theme doesn’t either. So I guess there is something else wrong.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.