Google Plus Embedded Post Disappears when I edit post

Community Forums Forums Design Tips and Tricks Google Plus Embedded Post Disappears when I edit post

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  Summer 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #103583

    melissamal
    Member
    Post count: 18

    Does anyone know why after I embed a goggle + post with its code into my wordpress blog under the “text” tab inside the article, and refresh it and view it, it’s there and looks great and then if I happen to edit the post down the road, and view it, the g+ embed is gone, but the code is still there inside the text tab when I edit it?

    I am missing something.

    Thanks!

    http://www.integrativenutritionaltherapies.com/
    #103595

    Summer
    Participant
    Post count: 1112

    If you’re switching between Visual and Text mode for viewing post edits, that is likely the culprit.

    The Visual editor munges the HTML (or javascript) of most object-style embeds, which is one reason they simplified things with the oembed features. Prior to that, if you pasted the old YouTube embed codes into a post in Visual mode, they wouldn’t work, and if you pasted them in Text mode they would work until you went back and edited that post again in Visual mode, which would cause the munging.

    So you’d have to either switch your default editor to Text in your User Profile (and switch to Visual if you have to for new posts), or never ever edit those embed posts again :)

    Apparently the oembed method for G+ (using only the URL of the post) or the shortcode method only works on WordPress.com hosted sites for now. Bummer.


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.