Google+ showing author name instead of link name

Community Forums Forums Design Tips and Tricks Google+ showing author name instead of link name

This topic is: not resolved

Tagged: 

This topic contains 18 replies, has 3 voices, and was last updated by  mborger 9 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #69285

    mborger
    Participant
    Post count: 107

    All of a sudden, sharing my blog posts on Google+ shows my author name as the link title and not the post title. This is only for Google+, not other platforms. I do use the Yoast SEO plugin but I’m not aware of this ever happening before and I’ve changed no settings. I don’t know if this is a Genesis issue or not. Here is my latest link below.

    http://bigrockinvestments.com/help-a-homeowner-friend/

    Any ideas? Thank you.

    http://bigrockinvestments.com/help-a-homeowner-friend/
    #69307

    Anita
    Participant
    Post count: 7429

    I just went to your Google+, the Link showing your name is pointing to a LISTING and not a POST. There isn’t any POST INFO with your Author name assigned there – at least it doesn’t look that way.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #69366

    mborger
    Participant
    Post count: 107

    Hi – thanks for helping me with this. Which link specifically are you referring to and on which page? I looked at the source code of the blog post itself and found: <meta
    property=”og:title” content=”Can You Help a Homeowner Friend in Need?”/>

    Maybe I’m looking at something that’s not related…?

    #69367

    Anita
    Participant
    Post count: 7429

    On your Google Plus – the second one down is labeled, “Back on market – HOT neighborhood! #honolulu #realestate #hawaii” and has your name. When I click it – it goes to a Listing – http://bigrockinvestments.com/listings/large-single-family-house-moanalua-gardens/.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #69368

    mborger
    Participant
    Post count: 107

    Yes, that’s a prime example of the problem. Any time I post a link, whether a post or the homepage, from that website onto Google Plus, the title shown is my author name and not the post time. I don’t know why it’s doing this. I don’t have this problem on Facebook, Twitter or LinkedIn, nor do I have this problem posting links from other websites onto Google+.

    There’s something wrong with my website at the moment.

    #69810

    mborger
    Participant
    Post count: 107

    I meant not the “post TITLE” in the above. It shows my name as the title, not the page/post title as it should be. It tried deactivating the Yoast WordPress SEO plugin, deleting both the site cache and CDN pull zone and trying again, but no change.

    #69856

    coralseait
    Participant
    Post count: 99

    Perhaps google is doing a little too much google foo ?

    http://yoast.com/google-page-title/

    Sometimes, I have to re-save things in Yoast SEO; for example after WP updates or even some plugin updates I notice my sitemaps will not work. So I just re-save Yoast SEO options.

    Also, very rarely, I’ve seen clearing open graph cache for sites fix things, such as for facebook http://facebookhelpdisk.blogspot.com.au/2013/07/facebook-open-graph-not-clearing-cache.html

    Note sure how google implements a cache or if they do however.

    Cheers!


    #69972

    mborger
    Participant
    Post count: 107

    Thanks – I’ve opened up a support ticket with stackoverflow. Looks like I’m not the only one this has happened to. The Yoast article is about this happening in the SERPs. I’m ok in the SERPs (for now) – it’s just sharing on G+.

    Some things I’ve ready seem to point to schema markup. I was looking into this but I don’t think I actually implemented any schema markup on the site. BUT – when I load the page source of my homepage, I do see one section about schema and points to my user/author profile. I don’t recall how it would have gotten there.

    Would this cause it to happen and, if so, what exactly would I do about it?

    • This reply was modified 9 months, 3 weeks ago by  mborger.
    • This reply was modified 9 months, 3 weeks ago by  mborger.
    #70443

    mborger
    Participant
    Post count: 107

    Any other info? I posted on another site and got this feedback:

    http://stackoverflow.com/questions/19692525/sharing-post-in-google-plus-pulls-author-name-as-title

    He recommends further work to (seemingly) undo some schema.org markup? How would the schema line even get there – is it part of AgentPress??

    Sounds like this might be a band-aid approach for another option that might be there. But — I don’t really understand schema.org implementation enough to really assess the viability of this solution.

    Thoughts?

    #70448

    coralseait
    Participant
    Post count: 99

    Both Yoast and Genesis Framework / Child themes (depending on version) implement schema markup, in fact that’s one of their pluses.

    You can see what structured data Google finds via the testing tool http://www.google.com/webmasters/tools/richsnippets?q=http%3A%2F%2Fbigrockinvestments.com%2Fhelp-a-homeowner-friend%2F

    What version of the Framework, Agent Press and Yoast are you using? Also, are you using any other significant plugins?


    #70450

    mborger
    Participant
    Post count: 107

    I don’t deny there’s value in schema, I just don’t know how it got in my site the way it is. I also manage http://funthingsapp.com and that doesn’t have any schema in the page source. But – both sites are running the most recent versions of Genesis, AgentPress and Yoast SEO.

    On bigrockinvestments.com , I just disabled all the plugins, deleted my browser cache as well as the CDN pull zone. The page source still showed the schema markup line. I just don’t know what’s putting it there — and what I can do about it, either deleting it or altering it in someway.

    #70451

    coralseait
    Participant
    Post count: 99

    Are you implementing page caching or other caching tools? I still see all of the Yoast OG markup in your source.


    #70456

    mborger
    Participant
    Post count: 107

    I have W3TC on both sites. Yes, the Yoast markup is there – I turned my plugins back on after testing the site without any plugins. W3TC was also disabled when I tested it, so it does not appear to be the result of any caching or plugins.

    #70458

    Anita
    Participant
    Post count: 7429

    Here are some links worth taking a look at for the Schema. I don’t see where you can remove it, but you can customize, edit or use a plugin. The new schema came with 2.0. If you can’t get it to work the way you want, you could always revert back to 1.9.2 as a last resort.

    http://bradpotter.com/microdata-manager-wordpress-plugin-to-optimize-schema-settings-in-the-genesis-framework/

    http://www.rfmeier.net/custom-microdata-with-genesis-2-0/

    http://yoast.com/schema-org-genesis-2-0/


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #70464

    mborger
    Participant
    Post count: 107

    Thank you – I will try to make the plugin work. However, I’m still mentally stuck at the place where the funthingsapp.com site does not show the markup yet it runs the same exact parent/child theme versions and Yoast SEO plugin. It just seems like that one line of schema markup has to be coming from somewhere….

    Another thing is that IF this is by default, then I can’t help but consider it a bug that needs fixing. Sharing posts on Google+ should retain the post name for sharing, not pull the author name as the title.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.