How can I change the font for my posts titles only?

Community Forums Forums Design Tips and Tricks How can I change the font for my posts titles only?

This topic is: not resolved

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  dev 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #64718

    jgentry
    Participant
    Post count: 125

    I’ve read how to import a font from google fonts, but I’m not clear on where to add it in the style sheet. Also, I’d like to change the font for my posts titles.

    Any insights?

    http://mentoringsons.com
    #64731

    dev
    Participant
    Post count: 451

    .home-bottom .featured-content .entry-title {
    font-family: Times;
    }

    (put in the font you want)

    As for where to put the import statement, Google gives you 3 methods that you can use to bring in the font. I like to use the html “link” method in the Genesis, Theme Options, Header box. Others like to use the @import in CSS. Your choice.

    Dev

    http://www.NewMediaWebsiteDesign.com

    #64736

    jgentry
    Participant
    Post count: 125

    Gotcha.

    I’ll try that now.

    Thanks!

    #64737

    jgentry
    Participant
    Post count: 125

    hmmm…don’t quit have it yet. I used the linked method and added the above code.

    Does it matter which line I enter the code?

    #64742

    dev
    Participant
    Post count: 451

    It looks like your CSS is screwed up. Replace line 2088 with this and see if it is what you want. Somehow the final } of the media query is missing:

    @media only screen and (max-width: 320px) {

    .header-image .site-title a {
    background-size: contain !important;
    }

    .site-title {
    font-size: 36px;
    font-size: 3.6rem;
    }
    }

    .home-bottom .featured-content .entry-title {
    font-family: Times;
    }

    #64766

    jgentry
    Participant
    Post count: 125

    Thanks for catching that for me!

    I’m still unable to change the font though. I’m sure I missed something.

    #64767

    jgentry
    Participant
    Post count: 125

    Here’s what I have in my wp_head:

    <link href=’http://fonts.googleapis.com/css?family=Roboto+Slab:400,700,300′ rel=’stylesheet’ type=’text/css’>

    #64769

    dev
    Participant
    Post count: 451

    Here is what you have at line 235 of your CSS:

    .home-bottom .featured-content .entry-title {
    font-family: Roboto+Slab:400,700,300;
    }

    That is not going to work. Where did you come up with that code code-construction? Delete it.

    Here is what you have at the end of your css:

    .home-bottom .featured-content .entry-title {
    font-family: serif;
    }

    Try this:

    .home-bottom .featured-content .entry-title {
    font-family: ‘Roboto Slab’;
    font-weight: 400; /* Or whatever value that you want */
    }

    Just importing the font in the HTML is not enough. You also have to explicitly designate it in the CSS… by overriding whatever the theme uses as a default… which looks like Oswald in your case.

    Dev
    NewMedia Website Design

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.