Metro Menu Bar Changing To Hover Color

Community Forums Forums Design Tips and Tricks Metro Menu Bar Changing To Hover Color

This topic is: resolved

This topic contains 5 replies, has 2 voices, and was last updated by  mezzers 1 year, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #32572

    mezzers
    Participant
    Post count: 17

    I am using the Metro theme, and the hover color for my menu items in the main menu under the header is blue. This works fine. But when I hover over a menu item and click to select it, the entire menu section changes to the hover color. I have tried everything to fix this but cannot figure it out.

    Any help would be grateful appreciated.

    My website is http://www.thereviewsquad.com

    Thanks in advance.

    Mary

    #32606

    braddalton
    Participant
    Post count: 8873

    Its a bit complicated because the menu has so many classes:

    I suggest you install the Firefox addon, Firebug and add change the values for each classes properties in real time using your browser before editing the style.css file.

    Here’s an example of the menu classes and how to style them http://www.wpbeginner.com/wp-themes/how-to-style-wordpress-navigation-menus/


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #32611

    mezzers
    Participant
    Post count: 17

    Hi Brad,

    Thank you so much, and thank you for the link showing examples of menu classes.

    I was just coming back to update the thread, as I kept a copy of the style.css file before I made any changes, and I put everything back to the original settings and still had the problem.

    Not being a techie, I was baffled, and after spending quite a lot of hours trying to figure out why the whole menu header changes to the hover color when I click on a menu item, I finally seem to have found the issue.

    The menu items I created are custom links, but I used pages and not posts for them. I changed one of them (jewelry) to go to a post, and it works perfectly.

    I did not realise that the custom urls had to be posts. I thought it would work for pages as well. Is that not possible?

    Mary

    #32617

    braddalton
    Participant
    Post count: 8873

    You can add any url as a custom link in the menu. Not sure why it changes the menu color. I try and stay away from the meny CSS and leave it as is becuse there’s so many classes its confusing.

    I know that the developers have reduced as much CSS code from the nav menu as possible.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #32619

    mezzers
    Participant
    Post count: 17

    Thanks Brad.  I can create the custom links in the menu using page urls without any problem. And the links work and go to the page without any issues.

    It’s only the menu changing color to the hover color when it is a page it goes to that’s the issue. It’s doesn’t do that if the custom url is a post.

    It’s very confusing, but I really appreciate you trying to help and for the information link on menu classes.

    Thanks Brad.

    Mary

    #32626

    mezzers
    Participant
    Post count: 17

    Just got an email from Jennifer at Copyblogger Media Support and she has explained what I did that caused the problem.

    Because I am still in test mode, I used the same page to link to for all the menu items, and so it caused all of them to change to the hover color when I selected any of them!

    Have fixed it now and learnt a lot in the process!

    Thanks again Brad for trying to help me – I really appreciate it.

    Mary

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.