Metro theme: adding "Welcome Text" widget per B Gardner's code – help?

Community Forums Forums Design Tips and Tricks Metro theme: adding "Welcome Text" widget per B Gardner's code – help?

This topic is: resolved

This topic contains 28 replies, has 4 voices, and was last updated by  Jen Baumann 1 year, 2 months ago.

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #39389

    anitac
    Participant
    Post count: 6992

    I see the widget there, it’s just not formatting correctly. Send me an email on my website and I will try to help you offline.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39390

    kay9
    Participant
    Post count: 45

    Wow I’m really confused now. I just cut and pasted and saved the code from braddalton and it’s still not working. :(

    This is what’s in there now:

    `/** Register widget areas */
    genesis_register_sidebar( array(
    ‘id’ => ‘welcome-text’,
    ‘name’ => __( ‘Welcome Text’, ‘genesis’ ),
    ‘description’ => __( ‘This is the welcome text widget.’, ‘metro’ ),
    ) );

    /** Add the welcome text section */
    add_action( ‘genesis_before_content_sidebar_wrap’, ‘custom_welcome_text’ );
    function custom_welcome_text() {
    genesis_widget_area( ‘welcome-text’, array(
    ‘before’ => ”,
    ) );
    }`

    And here is the CSS in there now:

    `/* Welcome Text WIDGET MY CODE THAT I CANNOT GET TO WORK
    ———————————————————— */

    .welcome-text {
    border-bottom: double #ddd;
    border-top: double #ddd;
    font-family: ‘museo-slab’, sans-serif;
    font-size: 30px;
    line-height: 1.0;
    overflow: hidden;
    padding: 25px 0;
    text-align: center;
    }

    .welcome-text p {
    font-size: inherit;
    line-height: 1.0;
    font-family: ‘museo-slab’, sans-serif;
    margin: 0;
    }

    `

    • This reply was modified 1 year, 2 months ago by  kay9.
    • This reply was modified 1 year, 2 months ago by  kay9.
    • This reply was modified 1 year, 2 months ago by  kay9.
    • This reply was modified 1 year, 2 months ago by  kay9.
    #39393

    braddalton
    Participant
    Post count: 8857

    The class for the widget is missing meaning the CSS code Brian also provided will not work as it uses that class
    [css]
    welcome-text
    [/css]

    Here’s the CSS using the above class which is generated by the PHP code but missing in Kay’s code. This is the reason the CSS isn’t working.
    [css]
    .welcome-text {
    border-bottom: double #ddd;
    border-top: double #ddd;
    font-family: ‘Lora’, serif;
    font-size: 30px;
    line-height: 1.0;
    overflow: hidden;
    padding: 25px 0;
    text-align: center;
    }

    .welcome-text p {
    font-size: inherit;
    line-height: 1.0;
    margin: 0;
    }
    [/css]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #39394

    anitac
    Participant
    Post count: 6992

    Send me an email on my website and I will look at your code from here.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39395

    braddalton
    Participant
    Post count: 8857

    @Kay9

    You are still missing part of the code.

    That is not the code I pasted as it is missing the new class which the PHP code generates.

    You are missing this:
    [php]
    <div class="welcome-text widget-area">
    [/php]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #39397

    anitac
    Participant
    Post count: 6992

    Brad, she isn’t using the PHP code like we are to show the entire code. It’s being stripped when she posts here.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39398

    kay9
    Participant
    Post count: 45

    I’m sorry you guys, I’m posting using the “code” tags. Is it still not really showing something?

    #39399

    anitac
    Participant
    Post count: 6992

    I emailed you back. Let me know if you are going to follow those instructions. If not, I’ll unsubscribe from here.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39400

    braddalton
    Participant
    Post count: 8857

    Try using:
    [php]
    [php]<?php echo ‘Hello World’; ?>[/php] FAQ number 5
    [/php]

    FAQ number 5. http://www.studiopress.com/forums/faq/


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #39401

    anitac
    Participant
    Post count: 6992

    I’ll let you guys go at it. I can’t go back and forth anymore. I’ll unsubscribe.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39402

    kay9
    Participant
    Post count: 45

    I can’t get anything to work now!!!

    #39403

    kay9
    Participant
    Post count: 45

    And the email I sent BOUNCED.

    #39411

    anitac
    Participant
    Post count: 6992

    I received your email if you are referring to mine and I replied back.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #39427

    Jen Baumann
    Keymaster
    Post count: 325

    We resolved it through the support desk. There was just a missing brace } in the media query before the added css. Case closed! :)


    If you need technical support for your theme please file a ticket.

    The forums are community based. Staff only monitors the forum for issues relating to the forum itself and to redirect users to where they need to go.

Viewing 14 posts - 16 through 29 (of 29 total)

The topic ‘Metro theme: adding "Welcome Text" widget per B Gardner's code – help?’ is closed to new replies.