Missing "Leave a Comment" on Newer Posts

Community Forums Forums Design Tips and Tricks Missing "Leave a Comment" on Newer Posts

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by  Bill Murray 1 year, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41584

    abbyunabridged
    Participant
    Post count: 1

    A while back I decided to disable the comments on my blog. I remember it taking me forever to figure out how to do it. Now, I want to turn them back on, but something strange is going on. There is a “Leave a Comment” link on my older posts (Sept 2012), but not on the new ones (May 2013). I have double checked the Theme Settings for Genesis, the Discussion settings for WP and I looked on the newer posts’ editing pages and the only thing related to comments I see on each page is a section where I can add comments of my own and where comments from others would show up if they could comment. I’m not really experienced with any programming or coding. I did inspect two different posts, one with comments enabled and one without using Firebug, but it didn’t appear to be anything I could fix on my own since there appears to be a whole line of code missing from the comments disabled posts.

    Please, help me.

    Thanks in advance!

    abbyunabridged.com

    #41592

    Bill Murray
    Participant
    Post count: 575

    On a post where you can’t enter comments, try clicking Screen Options in the upper right, make sure the Discussion option is checked, then scroll down to the Discussion metabox and make sure comments are allowed.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #41644

    abbyunabridged
    Participant
    Post count: 1

    I looked at the screen options and I’m not even seeing a Discussion box to check. These are the only options it gives me. Author Categories Tags Comments Date SEO Title SEO Description 

    Could a plugin be causing this problem?

    I have comments enabled through Genesis and in the Discussion section of the settings for WP.

    I am completely baffled as to what is going on here.

    #41753

    Bill Murray
    Participant
    Post count: 575

    On screen options you should see Slug and Excerpt, which are core WP checkboxes. So if you’re not seeing those, something is odd. A standard debugging step is to deactivate all plugins to see if it’s a plugin conflict. There are various approaches to this (such as picking 1/2 of them and starting there). After each deactivation, you’ll need to check a post edit screen to see if your screen options are back to normal.

    And just to clarify, I assume you are checking screen options on the post edit screen and you’re running the latest version of WP, which is 3.5.1?


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.