More Tag not working

Community Forums Forums Design Tips and Tricks More Tag not working

This topic is: not resolved

This topic contains 7 replies, has 3 voices, and was last updated by  Rosesilk 1 year, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23675

    Rosesilk
    Participant
    Post count: 17

    Hello,

    http://stress-free-mama.com/blog/

    I inserted a more-tag on the post “Stress Expert Jan Bruce…”, however the excerpt shows the typical content and ignores the tag placement.  Do you have any idea what is going on?

    Thank you.  I really appreciate your help.

    Julia

    #23855

    jodzeee
    Participant
    Post count: 216

    It seems to be working for me, did you find a fix?

    #23856

    Rosesilk
    Participant
    Post count: 17

    No.

    The more-tag is inserted after several paragraphs of content.  In the URL I gave you above, the content is displaying the default amount on content, as if there wasn’t a more-tag.

    #23859

    Bill Murray
    Participant
    Post count: 575

    It appears you misunderstand either how the more tag is used or how excerpts are generated. See this, specifically the notes just prior to usage. The more tag doesn’t work on the single post view.

    Your archive displays will honor your archive settings. If you feel your archives are not honoring your more tag placement and you’ve set your archives to display excerpts, your more tag may be too far down in the post content in a situation where you don’t have a manual excerpt. When your template calls for the excerpt and you have no manual excerpt, WP will deliver the first 55 words of the post. See this on excerpts. If you don’t like the automatic 55 word limit, you’ll have to enter a manual excerpt, which should then honor your more tag placement.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #23884

    Rosesilk
    Participant
    Post count: 17

    Ok, let’s start over again.  Either I am misunderstanding something or I’m not explaining what I want well.

    My archive page:  http://stress-free-mama.com/blog/  (This is NOT a single post page)

    What I want:

    I want the post “teasers” to display my content up to the more-tag, if there is a more tag.
    I would like the content formatting (paragraphs, etc.) to be present.
    I would like a live “read more” hyper-link to the rest of the post.

    What I have:

    The post “teasers” only display 350 characters
    The formatting is stripped.
    The setting is on “post content”.  If I change the setting to “excerpt”, the “read more” hyperlink disappears and I have “[...]” (no link) in its place.

    I have played around with post content vs. excerpts and I can’t get it to work.  I have also played around with the number of characters displayed.

    I am using the Agency theme.

    Right now, I only have 1 post with the more-tag in it–the top post called “Stress Expert Jan Bruce…”

    How do I get from what I have to what I want?

    Thank you again for your help.  I have tried to read the WordPress codex and get this figured out but there is something I am missing.

    Julia

     

    #23889

    Rosesilk
    Participant
    Post count: 17

    OK, I figured it out and I’m going to post my answer in case it helps someone else.

    I can get what I want with these settings:

    “post content” (NOT excerpt)
    Delete any character limit
    Uncheck the “include featured image” box if you have both a post image and a featured image.

    I can see that this works with 1 problem–I only recently started using the more-tag.  The posts without a more tag will show the entire post in the list.  I had thought that the character limit was only used if there was no more tag but it seems like if you put a character limit in the box, it overrides the more-tag.

    Correct me if I’m wrong…

    Thank you for your help.

    #23895

    Bill Murray
    Participant
    Post count: 575

    1) The formatting will always be stripped on archives when you choose the Display post content option with a content limit. See the note on your Genesis theme settings. Unless your child theme makes changes, none of this is child theme dependent or even Genesis dependent. It’s standard WP.

    2) If your archive settings are set to Display post content, regardless of whether you set a content limit or not, your placement of the more tag should be respected – with an important note. If you set a content limit of 100 characters (and note this is characters, not words, whereas excerpts are counted in words), and you manually place your more tag at 200 characters, your placement will never take effect, because the content was cut off at the first 100 characters. Right now, it appears you have your content limit set for about 345 characters, but your manual more tag appears after about 1100 characters, so it will never have an impact.

    3) Because of #2, you could either: a) not set a content limit and manually place a more tag in every post or b) set a content limit that was sufficiently large for all or your posts but be sure to place a more tag closer to the start of your content than that limit.

    4) Excerpts do not automatically add a link to the post content. A more tag could be automatically added to the end of all excerpts using a filter. Therefore, another option is to set your archives to display excerpts, create manual excerpts when you want something longer than 55 words, and add a filter so you get a more link at the end of every excerpt. HTML is allowed in excerpts, but shortcodes aren’t processed. I think for you, this is more work without a benefit. Manual excerpts are used by folks who want content that is different from the post content in archives.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #23899

    Rosesilk
    Participant
    Post count: 17

    Hi Bill,

    Thank you so much for hanging in with me on this one.  I appreciate your help.  Thank you.

    I think the information I missed was that once there is a character limit, the HTML is stripped.  I read that warning multiple times but I didn’t realize it was the character limit that activated it.  When I saw the content without formatting, I misinterpreted what was going on.

    I think I will keep no character limit for now, and maybe I’ll put a more tag into every post at some point in the future.

    Your explanation is very helpful.  Have a great day.

    Julia

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.