My theme is producing duplicate content

Community Forums Forums Design Tips and Tricks My theme is producing duplicate content

This topic is: not resolved

This topic contains 14 replies, has 4 voices, and was last updated by  ToniLaird 3 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #49662

    Nandita
    Participant
    Post count: 32

    My blog url is SEOHour.com

    I’m using Copyblogger (free theme) on Genesis Framework. I’m not using any SEO Plugin on my blog since the beginning.

    I’m facing “Duplicate Content” issue. Google has been indexing multiple pages (pagination 1,2,3,4…) of my blog. I’ve done the best possible SEO Setting under Genesis. But still facing the problem.

    My setting is like Genesis —> SEO Setting

    Apply nonarchive to the home page – Check

    Apply noindex to Category archive – Check
    Apply noindex to Tag archive – Check
    Apply noindex to Author archive – Check
    Apply noindex to Date archive – Check
    Apply noindex to Search archive – Check

    Apply nonarchive to Entire Site – Check

    Apply nonarchive to Category Archives – Check
    Apply nonarchive to Tag Archives – Check
    Apply nonarchive to Author Archives – Check
    Apply nonarchive to Date Archives – Check
    Apply nonarchive to Search Archives – Check

    Canonical Paginated Archives – Check

    So Google is not indexing my Categories, Tags etc. but still indexed 10 duplicate pages from the Pagination. I’ve included an example URL below for reference.

    How to prevent and getrid of these already indexed duplicate pages?

    • This topic was modified 1 year, 1 month ago by  Nandita.
    • This topic was modified 1 year, 1 month ago by  Nandita.
    https://www.google.com/search?num=20&biw=1360&bih=624&q=site%3Aseohour.com&oq=site%3Aseohour.com&gs_l=serp.12...26612.27456.0.29226.11.5.0.0.0.3.127.529.1j4.5.0....0...1c.1.19.serp.7nUiQQLEJ_g
    #49667

    braddalton
    Participant
    Post count: 9415

    You could use GWMT to remove url’s from the index manually. https://support.google.com/webmasters/answer/59819?hl=en


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #49669

    Nandita
    Participant
    Post count: 32

    Hi,

    But Google WMT doesn’t remove live URL. The page has to return 404 or 401 status code. Moreover the removed URLs last for 90 days and again appear in Google search after that.

    #49671

    braddalton
    Participant
    Post count: 9415

    You can add them to your robots.txt immediately.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #49751

    Nandita
    Participant
    Post count: 32

    Can you please tell me – Which file to add in robots.txt to avoid pagination issue (duplication)?

    #101073

    robindean
    Member
    Post count: 5

    Yes, I’m going to reopen this thread.

    I’m having the same problem on streamline-pro. Basically, I want to “noindex, follow” ALL PAGINATION.

    How do I do this?


    Shabadoo!

    #101081

    robindean
    Member
    Post count: 5

    After a bit of Googling, I found a solution.

    For my theme and it’s customizations in particular, I ended up simply adding this to my functions.php file:

    function noindex_pagination() {
    echo ‘<meta name=”robots” content=”noindex,follow,noarchive,noodp,noydir”/>’;
    }
    if (substr($_SERVER['REQUEST_URI'], 0, 6) == ‘/page/’) {
    remove_action(‘genesis_meta’,’genesis_robots_meta’);
    add_action(‘genesis_meta’,’noindex_pagination’);
    }


    Shabadoo!

    #104624

    ToniLaird
    Member
    Post count: 61

    I’ve just posted a support ticket as I am also getting getting ‘duplicate title tags’ /, /page/2/, /page/3/, /page/4/
    However, these pages all revert back to the static home page!

    Nandita, did Robin’s fix work for you as I may well try it?

    • This reply was modified 3 months, 3 weeks ago by  ToniLaird.
    • This reply was modified 3 months, 3 weeks ago by  ToniLaird.
    #104629

    robindean
    Member
    Post count: 5

    I’d be willing to bet that the reason they all refer back to the home page is that they’re setup for canonical use. That basically tells Google that they shouldn’t be linked to but that they should redirect to the first in the series … which DOESN’T solve the problem of them appearing in the search engines. Studiopress, give us the option!

    My solution works for my own theme and I hope it will for everyone else.

    Best.


    Shabadoo!

    #104630

    Nandita
    Participant
    Post count: 32

    Hi,

    I don’t know; by adding Robin’s code in the functions.php file my theme crashed. I’m using EPIK theme on my blog.

    Thank you.

    #104705

    ToniLaird
    Member
    Post count: 61

    I’ve made a few changes but as Google is not ‘real time’ I’ll have to wait around 5 days to see if it works!

    #104709

    Nandita
    Participant
    Post count: 32

    Hi Toni,

    If it will work; please do share your tricks here.

    Hope for the best. And wish you all the luck :)

    #104710

    robindean
    Member
    Post count: 5

    My own site is on the Genesis framework. Is yours, Nandita? Maybe that’s why it doesn’t work.


    Shabadoo!

    #104840

    Nandita
    Participant
    Post count: 32

    Hi Robin,

    We all are here only because we all have Genesis framework. Very few people here who use a SP Child Theme without a Genesis Framework.

    So, keeping this in mind we should answer others’ questions.

    Thanks for clarifying the fact :)

    #104846

    ToniLaird
    Member
    Post count: 61

    What I have just discovered is that in the Google Webmaster I had not set the ‘preffered domain’ as with my other sites!

    On the Webmaster Tools Home page, click the site you want.
    Click the gear icon , and then click Site Settings.
    In the Preferred domain section, select the option you want

    You need to chooses whether to use www or not. This could be the cause. I’ll revert back in a few days

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.