Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING

Community Forums Forums Design Tips and Tricks Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING

This topic is: resolved

This topic contains 5 replies, has 3 voices, and was last updated by  esanger 2 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #36300



    I’m new to the forum. While attempting to add a favicon code snippet to my functions.php, I am receiving this error.

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/classy4/public_html/wp-content/themes/blissful/functions.php on line 15

    functions.php looks like this…
    /** Start the engine **/
    require_once( TEMPLATEPATH . ‘/lib/init.php’ );

    /** Child theme (do not remove) */
    define( ‘CHILD_THEME_NAME’, ‘Blissful Theme’ );
    define( ‘CHILD_THEME_URL’, ‘’ );

    /** Add support for custom background */

    /** Add support for custom header */
    add_theme_support( ‘genesis-custom-header’, array( ‘width’ => 960, ‘height’ => 120 ) );
    /** Unregister 3-column site layouts */
    genesis_unregister_layout( ‘content-sidebar-sidebar’ );
    genesis_unregister_layout( ‘sidebar-sidebar-content’ );
    genesis_unregister_layout( ‘sidebar-content-sidebar’ );

    /** Add support for 3-column footer widgets */
    add_theme_support( ‘genesis-footer-widgets’, 3 );

    /** Add new image sizes */
    add_image_size( ‘mini-thumbnail’, 75, 75, TRUE );
    add_image_size( ‘small-thumbnail’, 110, 110, TRUE );

    /** Reposition the Primary Navigation */
    remove_action( ‘genesis_after_header’, ‘genesis_do_nav’ );


    Can anyone please tell me what I’m missing? I have erased the code snippet I added and perhaps I erased something I shouldn’t have. I am really new to all of this and still learning so any help would be greatly appreciated!

    Thank you,



    Download that file from your server and keep a copy on your local pc.

    Upload a new copy of that file to your child themes folder.

    You may have copied and pasted the code in your WordPress theme editor which can change the code so it doesn’t work.

    Best to copy the raw view of the code and paste it directly into the file using a text editor like Notepad++.

    You can grab a new copy your functions.php file from a fresh download of the theme (if its the latest version) or a backup of the theme.



    I have redownloaded the theme but I don’t see where I can grab a new copy of the functions.php file?

    The theme is the Blissful theme from studiopress.



    Found it! I have replaced the functions.php with the newly downloaded one and I am still receiving the error… (?)



    For those having similar issues. The trick that finally worked was…I went into filezilla and renamed my functions.php to functions_hold.php then uploaded a newly downloaded functions.php from my theme folder.



    Had a similar issue.  Classyclutter….. thank you.  Tried your method and it worked great!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.