Simple Hooks Home Page Generate Box Help Please

Community Forums Forums Design Tips and Tricks Simple Hooks Home Page Generate Box Help Please

This topic is: not resolved

This topic contains 9 replies, has 2 voices, and was last updated by  anitac 1 year, 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #25169

    julesonline
    Participant
    Post count: 24

    Hi :)

    To add in a custom lead capture box to the Generate theme I used the Simple Hooks plugin instead of the “Generate Box Widget” - genesis_after_header Hook.

    The form sits perfectly on the Home Page however it is also showing on every page. How do I stop it showing on all pages please as only wish to have it on the Home page of the website.

    Thank you so much

    Jules :)

     

     

    #25171

    anitac
    Participant
    Post count: 6991

    You need to add a conditional tag to tell it “home only” in your code.

    [php]<tt><span class="external text">is_home()</span></tt> [/php]


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #25173

    julesonline
    Participant
    Post count: 24

    Hi Anitac

    Thank you, where abouts do i put this code piece please? I just tried to add it into the simple hooks box with the lead capture code but it didn’t work, so guessing I placed it into the wrong area. I also have both boxes ticked within the simple hooks area.

     

    #25202

    anitac
    Participant
    Post count: 6991

    I would need to see your actual code that you put inside the Hook to determine where you need it.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #25215

    julesonline
    Participant
    Post count: 24

    Hi Anitac

    Ok thank you :) second try at posting it in and i have broken urls up /changed the site name on purpose.

    <div style=”background:url(http :// the webiste .com/wp-content/uploads/2013/03/top-form1.jpg); width:959px; height:255px; margin-left:auto; margin-right:auto;”>
    <form action=”http:// www. aweber.com/scripts/addlead.pl” method=”post” style=”padding:0px; margin:0px;”>
    <input name=”meta_web_form_id” value=”1837090802″ type=”hidden”><input name=”meta_split_id” value=”” type=”hidden”>
    <input name=”unit” value=”listname” type=”hidden”><input name=”redirect” value=”redirect_e02e1225bc9b89cf22209ebfa0d62702″ type=”hidden”>
    <input name=”meta_adtracking” value=”adtrackid” type=”hidden”><input name=”meta_message” value=”1″ type=”hidden”>
    <input name=”meta_required” value=”name,email” type=”hidden”/>
    <input type=”hidden” name=”meta_tooltip” value=”” />
    <div style=”width:280px; float:right; padding-top:102px; padding-right:13px;”>
    <div style=”width:260px; float:right; padding-right:10px;”>
    <label style=”padding:0px; margin:0px; float:left; width:260px;”>
    <input name=”name” type=”text” id=”name” style=” width:260px; height:22px; margin-top:0px; margin-bottom:2px; float:left;” value=”Name” onFocus=”if(this.value==this.defaultValue)this.value=”;” onBlur=”if(this.value==”)this.value=this.defaultValue;” />
    </label>

    <label style=”padding:0px; margin:0px; float:left; width:260px;”>
    <input name=”email” type=”text” id=”email” style=”width:242px; height:12px; margin-left:0px; margin-top:4px; margin-bottom:4px; float:left;” value=”Email” onFocus=”if(this.value==this.defaultValue)this.value=”;” onBlur=”if(this.value==”)this.value=this.defaultValue;” /> </label>

    </div>
    <div style=”width:280px; float:right; padding-top:5px;”><input name=”” type=”image” src=”http: // the website .com/wp-content/uploads/2013/03/do-it-btn.png” /></div>
    </div>
    </form>
    </div>

    #25446

    julesonline
    Participant
    Post count: 24

    Hi All

    Sorry to bump however still lost as to where to place the extra tag line. Would anyone know please where the tag needs to be placed in my code that Anitac has specified for me to do?

    Have a great day!

    Thank you

    Regards Julie :)

    #25582

    julesonline
    Participant
    Post count: 24

    Still hoping to get some help here please. Thank you so much.
    Regards

    Julie

    #25615

    anitac
    Participant
    Post count: 6991

    Please share a link to you website so I can take a look. That code you provided is not what goes in the hook area.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #25638

    julesonline
    Participant
    Post count: 24

    Hi Anitac

    Thank you so much for coming back and responding. I worked out the code should of just gone in a text box placed into the Generate widget and with fiddling of the template code was able to have the lead box placed in the area the default generate box sat.

    Have an awesome day Anitac

    Regards

    Julie :)

    #25663

    anitac
    Participant
    Post count: 6991

    Thanks, glad you got it figured out.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.