Spacing after apostrophe

Community Forums Forums General Discussion Spacing after apostrophe

This topic is: resolved

This topic contains 10 replies, has 4 voices, and was last updated by  Kary 7 months, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #60203

    Kary
    Participant
    Post count: 41

    Does anyone know why my StudioPress theme is putting a huge space after an apostrophe? It only happens after a number, not a letter. For example 1′s will produce something that looks like this 1′ s.
    However, it doesn’t happen after a letter.

    I’ve changed the font face. I’ve looked at it in both chrome and safari. And it doesn’t happen if I use the default theme on the StudioPress theme. I have the “Pretty Young Thing” theme installed. This is driving me NUTS. I’ve tried going in a replacing the apostrophe with the HTML code (not desirable); but of course WordPress just converts it right back to the apostrophe, so no joy there either. Except for changing themes, I’m at a loss here.

    I’ve linked to a short blog post that has an apostrophe after a number in the first line so if it’s showing in your browser, you should see it right away.

    http://www.unstuckification.com/laundry-day/
    #60208

    Sridhar Katakam
    Participant
    Post count: 851

    I see that in generated HTML, it shows that the character being used is not actually a apostrophe, but something similar.

    Try editing the entry in Text view and change

    Even laundry day can be a little fun for Type 1′s because ....

    to

    Even laundry day can be a little fun for Type 1's because ....


    #60249

    Kary
    Participant
    Post count: 41

    Hi Sridhar, i appreciate your help. But this isn’t the way I’m typing the apostrophe, its the way the theme is rendering what has been typed. I have come to discover that it is only happening in “Pretty Young Thing” theme. I have created some screen shots that show what I’m talking about. It is only in the PYT theme where the apostrophe spacing is a problem and only when the apostrophe is typed after a number.

    Yes, I realize technically the solution is to just use the entity number or name. HOWEVER, I have a few problems with that. First, its a PITA to remember to do this each and every time. Secondly, I shouldn’t have to. Also, if I inadvertently go from TEXT edit to HTML edit, WordPress strips out the entity number or entity name and replaces it with the same apostrophe I’d type with my keyboard…and I’m right back where I started.

    Anyone can see the test page I made here – Test Page

    • This reply was modified 7 months, 3 weeks ago by  Kary.
    • This reply was modified 7 months, 3 weeks ago by  Kary.
    • This reply was modified 7 months, 3 weeks ago by  Kary.
    • This reply was modified 7 months, 3 weeks ago by  Kary.
    #60349

    Kary
    Participant
    Post count: 41

    Well….since I’m not getting an answer here. I guess the next step for me is to report a bug in the PYT theme. If that doesn’t work, then I’ll need to use another theme and ditch this one.

    #60350

    Sridhar Katakam
    Participant
    Post count: 851

    Have you tried contacting the official support by sending them a ticket?

    http://my.studiopress.com/help/


    #60352

    dev
    Participant
    Post count: 408

    Here is your CSS:

    body, h1, h2, h2 a, h2 a:visited, h3, h4, h5, h6, p, select, textarea {
    color: #666;
    font-family: "Lato", "Century Gothic", AppleGothic, Arial, sans-serif;
    .
    .
    }
    

    I don’t think is the the theme, but the font. You are using Lato. Use a different font, like Arial and the space goes away. Maybe override your CSS to:

    font-family: "Arial", "Century Gothic", AppleGothic, Arial, sans-serif;
    }
    

    Why Lato does this spacing thing is beyond my pay grade. No idea.

    Dev

    http://www.NewMediaWebsiteDesign.com

    #60372

    Kary
    Participant
    Post count: 41

    Thanks Dev…that was the problem. When I first installed the theme and noticed the problem I DID change the font. Lato was not the font that came with the theme originally. So I tried changing it but to no avail. I suppose I never tried Arial. I can imagine that would be the case since I don’t like Arial. But I guess I’m stuck with it for now if I keep this theme. It’s the darndest thing. I have several blogs that use Google fonts and Genesis themes. i’ve even got another one that uses Lato. But this is the first time I’ve ever noticed this happening with the apostrophe’s.

    thanks for your help.

    #60404

    eamonmoriarty
    Participant
    Post count: 150

    Strangely the character which is being inserted is not an apostrophe but the prime symbol (used for number of minutes etc).

    But I wonder should it have bothered you at all? I think the plural of ‘Type 1′ is ‘Type 1s’ (without an apostrophe). I noticed you are putting apostrophes where they are not needed, as in your post above:
    ‘But this is the first time I’ve ever noticed this happening with the apostrophe’s.’ I think this should read:
    ‘But this is the first time I’ve ever noticed this happening with the apostrophes.’

    Pedantic, I know, but I think that is correct.


    Eamon Moriarty
    EM Dzine

    #60423

    dev
    Participant
    Post count: 408

    The only other thing that I can think of that is causing Lato to screw up is maybe in WP Settings, Writing you have the boxes about emoticons and XHTML checked and perhaps that is causing the issue?

    Otherwise, look through the style.css file and see if you can see any code… maybe webkit options that is causing this?

    Or maybe it is the ‘prime’ character that is the culprit. Or maybe browsers are seeing it as an ‘accent’ mark and is putting in a space?

    I noticed that it happened on “Times” font too, maybe it isn’t just Lato. Why it goes away with Arial is weird.

    I would send a note to the theme author and ask him/her to check it out for you…. unless it was a free theme in which case… good luck with all that!!

    Let us know what you find out.

    #60449

    Kary
    Participant
    Post count: 41

    Dev, Again thank you for your help. I just want Support to understand that the problem with the apostrophe is happening with the Century Gothic…which is the DEFAULT font coded in the CSS for this theme.

    I changed it to Lato trying to fix the problem. I tried a few fonts, but none work. I’ve used Lato on a few blogs and have never had this problem. I’ve changed it back to the default CSS in case anyone wants to see it. Here is the test page that shows the kerning problem.

    http://www.unstuckification.com/test-page/

    Eamon, I don’t want to slice hairs with you. But a few things…yes, you are being pedantic and not really helping to solve the problem. But no matter. I get you. Really I do. My husband can be very similar and just can’t help himself. I’ve learned to ignore him as it prevents a lot of arguments. LOL

    Secondly, although dates like 1950s or 50s are not typed with an apostrophe, I believe that numbers like 1, 2, 3, 4 can go either way. Maybe not absolutely correct…I think it is easier to read and comprehend the meaning. Heck, even Destiny’s Child and Mariah Carey named an album #1′s. LOL

    Besides, the woman who “invented” the system I’m writing about types it that way. There is a community of thousands and thousands of people who type it that way. So in order to be more easily understood (grammatically correct or incorrect), I’m typing it that way.

    #60468

    Kary
    Participant
    Post count: 41

    I have found the culprit. It is odd…but it is in the CSS and probably only appears on Macintosh computers. The default CSS is…

    font-family: “Century Gothic”, AppleGothic, Arial, sans-serif;

    Removing the AppleGothic font from the font-family solves the problem. That’s it. So the new CSS looks like this…

    font-family: “Century Gothic”, Arial, sans-serif;

    By removing that one font, it doesn’t matter what the ‘lead’ font is…Lato, Century Gothic, or any other Adobe Edge Web Font or Google Font. It all works as you would expect. So if you’re using the PYT Theme, even if you don’t have a Macintosh, visitors to your site might be viewing with a MAC and are seeing the weird kerning occur with apostrophes after numbers.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Spacing after apostrophe’ is closed to new replies.