Stuck on Genesis Responsive Slider All Day

Community Forums Forums General Discussion Stuck on Genesis Responsive Slider All Day

This topic is: not resolved

This topic contains 10 replies, has 6 voices, and was last updated by  dtdolphin 1 year, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #18825

    MoodyRiviera
    Participant
    Post count: 62

    Hello,

    After spending all day on this I’m about to give up, so hoping someone here can help. I’ve set up a test site using the Agency theme and the Genesis Responsive Slider. Without too much trouble, I managed to get the slider to display my photos, and also some text, but no matter how many different combinations of settings I use for the slider, I just can’t get the slider to look right.

    I’ve finally reset everything to the settings shown in the tutorial that came with the theme, but if you look at the page you will see that there are no “Continue Reading” links, and the text just seems to run to the bottom of the  white box alongside the images. I’d like to get the slider to look the way it looks in the Agency demo.

    Using various combinations of settings during the day, the slider has sometimes had the “Continue Reading” links…sometimes has had the link in a blue box…sometimes has had the white text box only extending part way down…it’s been all over the map. Here’s the link to the site:

    http://www.thequidnunc.com

    I would really appreciate any help.

    Thank you.

     

     

    #18865

    Hard Boiled Greg
    Participant
    Post count: 88

    If you are having trouble getting your site to appear the way it does in the demo, you can (and should) submit a ticket to the help desk.


    Website: Hard Boiled Greg Twitter: @hbgreg

    #18890

    UT Mod
    Participant
    Post count: 160

    and maybe you can try and activate “excerpt” mode ON for text in the slider, instead of “content” or something. I never used that theme but it may be some basic issue. As in excerpt case, the continue reading link shows itself.

    #18927

    rolphkropp
    Participant
    Post count: 4

    Hello,
    I’m setup a Executive Theme with a Genesis Responsive Slider but too much trouble, I managed to get the slider to display my text/photos, but the view changes in px high. I send a ticket yesterday evening to the helpdesk, I hope they will respond asap.
    My testsite: http://www.rolphkropp.nl
    If I have a look in the forum many people struggle with the slider, maybe StudioPress can support us with a extra video for WordPress TV,  at http://studiopress.tv/
    I would really appreciate any help.

    Thank you.

    #18946

    MoodyRiviera
    Participant
    Post count: 62

    First, thanks to all who have offered help. I really appreciate it.

    To Vajrasar, thanks for the suggestion: Yesterday, while being stuck on tis all day, I tried probably 50 or 60 various combinations of settings, including what you suggested. Today, with the settings at default, I tried your suggestion, and the slider suddenly got much closer to the look I wanted. I played with a few more settings, and finally got it working the way I wanted…pretty much…at least for now. Thanks so much.

    To Rolphkropp, thanks for your contribution. I hope that if the helpdesk comes up with some answers that maybe you will let us know somehow what they said. As you said, many people seem to have trouble with this slider, so it would be great if there were some fixes, and a real tutorial.

    To anyone who’s interested, here are some notes on what I did, including the settings that finally made the slider work reasonably well:

    A. I noticed that if my post title was too long, it would cause a problem, so I shortened up my page titles so they would be sure to not go more than one line.

    B. Genesis-Responsive Slider settings I used…only listing the ones I think are relevant to this discussion:

    Type of Content: Post

    Taxonomy and Terms: -slider
    I set up the posts I wanted to use with the slider in a category of slider.

    Do not link Slider image to Post/Page? Unchecked.

    Display Post/Page Title in Slider? Checked.

    Display Content in Slider? Checked.

    Hide Title & Content on Mobile Devices? Checked.

    Select one of the following: Display post excerpts.

    More Text (if applicable): Continue Reading

    Limit content to    characters. I left this blank. When I tried using settings such as 100 or 150 or 200 etc., it caused more problems.

    Slider Excerpt Width (in percentage): 29  Some other settings I tried resulting in the white text box where the excerpt would appear to be too short.

    Excerpt Location (vertical): Top

    Excerpt Location (horizontal): Right

     

    Not sure any of these settings matter much, but maybe will help someone.

     

     

     

     

    #18949

    rolphkropp
    Participant
    Post count: 4

    Hello,
    Thanks helpdesk for your support and they came up with some answers.
    I change the settings and it’s looks nice.
    I first set the pages in portfolio with photos dim. 1140×445 px

    Below the info from the helpdesk:
    The slider uses images that are “attached” to posts. This means that the images must be uploaded from the post or page edit screen rather than inserted from the WordPress media center.  To upload from the post or page edit screen, you need to use the Add Media button directly above the editor.  The slider will use the first image uploaded to the post as the featured image OR the image set as the featured image using the “Set Featured Image” function on the right of the editor.

    If you’ve uploaded the images prior to setting up the slider, you may need to regenerate your thumbnail images using this plugin:http://wordpress.org/extend/plugins/regenerate-thumbnails/.

    Thankx.

    Kind Regards, 

    Rolph

    #18966

    dgregfly
    Participant
    Post count: 4

    Thanks for this thread, I have been driving myself nuts trying to figure this out!  Your settings really helped, and then I also realized that the theme counts the excerpt as the first 55 words, so if I used big words, the text ran outside the lines of the slider, but a one line title plus 55 normal sized words to start and the slider looks great!

    #19037

    MoodyRiviera
    Participant
    Post count: 62

    Wow, dgregly, that’s very helpful. While I was driving myself crazy with this thing yesterday, I did notice that it seemed to make a difference what kind of text was in my post…(which seemed to make no sense to me, but couldn’t figure out what was making the difference)…and now I see what you’re saying that the script seems to count *words*.

    That’s great to know. Guess it’s time to start writing at a first-grade reading level…ha ha ha.

    And thank you rolphkropp for the further information.

    I think that in the next week or so, I’ll do a video tutorial on this slider…the setup, and some helpful hints about it. Maybe it will help a few people.

     

    #19073

    dtdolphin
    Participant
    Post count: 4

    ok this FINALLY worked for me, to get the home page slider looking like the demo, with a nicely spaced button….

    1. Add the plugin Genesis – Responsive Slider

    2. create a category called: slider

    3. Create 3-5 pages or posts you want to show up in the slider on the home page , and put them under the category you just created ‘slider’

    ***IMPORTANT these pages must start with text first – don’t insert an image right off the top or it will drive you crazy

    ***IMPORTANT you need to add a ‘more tag’ into the page, on a separate line in order for the button to be spaced properly

    almost there…..

    4. go to Appearance > Widgets – and add the Genesis – Responsive Slider widget to the HomeSlider widget area

    5. go to Genesis > Slider Settings – change the following to:

    By Taxonomy and Terms > choose the category ‘slider’

    Display Post/Page Title inSlider? > check it (yes)

    Display Content in Slider? > check it (yes)

    Hide Title &Content on Mobile Devices > check it (yes)

    Select one of the following: Display post content

    More Text > Continue Reading (or what ever you want)

    Limit content to > (leave it blank)

    Slider Excerpt Width > 30

    Excerpt Location > Top

    Excerpt Location > Right

    Save it.

    All done!

    That only took me all day….

    ***Other notes: if the text content on the slider is a mess, choose less of it by moving your ‘more tag’ on each page/post in the slider category.

    Remember that the more tag has to be on it’s own line for the button spacing to work.

    #19089

    MoodyRiviera
    Participant
    Post count: 62

    Thanks for this additional information, dtdolphin. I’m making notes of all these things for my future use.

    It’s interesting that you mention using the More tag, because when I used the More tag (based on what a guy said in a tutorial I found somewhere), it caused the problems I was having to get even worse.

    And so I eventually set up my posts with *no* More tags, and now have a slider that seems to be working reasonably well. At least for now.

    Crazy stuff.

    #19092

    dtdolphin
    Participant
    Post count: 4

    I know… after a while you loose track of all the combination of things you’ve tried… I’m making notes for future reference too, because I’m sure to forget.

     

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.