Style.css changes not appearing in website

Community Forums Forums General Discussion Style.css changes not appearing in website

This topic is: not resolved

This topic contains 11 replies, has 5 voices, and was last updated by  nickth 7 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #103419

    nickth
    Member
    Post count: 7

    Everyone raves about StudioPress, but this has been a nightmare to work with. The latest headache is that changes made to style.css in the Education child theme are not being reflected in the website. I wanted to update the header width from 380px to 594px. For some reason I was able to change the size back from 151px to 120px, but not the width. When I view the style.css via FTP, the change is there. When I rename the style.css to something else, the style.css STILL shows in browsers like FF and Chrome, even after I clear the cache. I had this problem before and thought it might have been server side caching, since I don’t have any plugins to do caching, and HostGator said to add the plugin Remove Static Query Strings, and that solved it that time. Now in FF in Firebug there doesn’t seem to be a static query string or alternate css file, but style.css without the change is still showing up, and in Chrome in Firebug, it says style.css:527 or some random number. This is so weird. Any idea why this is happening and how to fix it?

    http://immanagers.com/namw/
    #103422

    neilgee
    Member
    Post count: 133

    Its the CSS that is at fault – you have a background image set to an inline element -> a tag

    This will make it visible but I would consider applying the background image to the #title-area

    #title a {
    background: url(http://immanagers.com/namw/wp-content/uploads/2014/04/header-namw.jpg) no-repeat !important;
    width: 600px;
    display: block;
    height: 148px;
    }
    
    #title-area {
    float: left;
    overflow: hidden;
    padding: 27px 0 0;
    overflow: hidden;
    width: auto;
    }
    
    #header .widget-area {
    float: right;
    min-height: 0px;
    padding: 25px 0 0 0;
    position: relative;
    width: 740px;
    }

    #103445

    Andrea Rennick
    Keymaster
    Post count: 1437

    Note we have no built in caching in our themes. If you;re making changes t the right css file, there’s nothing in Genesis to prevent it from showing up on your site.


    **forum signature**
    If you need technical support for your theme please file a ticket.

    The forums are community based. Staff only monitors the forum for issues relating to the forum itself and to redirect users to where they need to go.

    Twitterholic

    #103484

    nickth
    Member
    Post count: 7

    That didn’t work. Something in the theme is definitely over-riding my custom changes. Check this out, I changed the width from 380px to 594px in the WP editor in Education style.css:

    http://awesomescreenshot.com/01f2qyvc5a

    But then when I hard refresh and view source on the site, the width now appears as 100% !important!

    http://awesomescreenshot.com/0d12qyvw21

    How could the CSS possibly be showing in one way in the editor and differently on the site and not reflecting my changes?! This is sooo annoying.

    #103489

    essaysnark
    Participant
    Post count: 342

    Well it looks to me that you have a typo with a partially-commented block of CSS in http://awesomescreenshot.com/0d12qyvw21 – I’m seeing

    /* .header-image .title-area,

    as the first line.

    #103490

    nickth
    Member
    Post count: 7

    Well that’s an interesting observation. It’s actually fully commented out: http://immanagers.com/namw/wp-content/themes/education/style.css

    I asked my web developer to take a look so he might have done that. But still, why doesn’t THAT code appear in the WP editor for style.css, and only appear through View Source > style.css on the website? Because if that code WERE in the editor, I could easily fix it.

    #103491

    essaysnark
    Participant
    Post count: 342

    Have you tried disabling all plugins? Not familiar with that Responsive Header one but it seems suspicious. Working with a clean slate with something like this will help.

    Edit: The plugin isn’t suspicious (Nick is well respected Genesis developer) but it looks like it may not have been updated in some time, and lots has changed with Genesis 2.0, plus you’re trying to do something with the header which is where my “suspicious” comment was intended vis a vis the plugin.

    • This reply was modified 7 months, 3 weeks ago by  essaysnark.
    • This reply was modified 7 months, 3 weeks ago by  essaysnark.
    #103495

    nickth
    Member
    Post count: 7

    Good idea, ty. Once I disabled “Remove query strings from static resources” then the changes appeared. I still don’t get how there could possibly be two style.css files when only one is showing via FTP on the server… any idea how that works?

    Because the whole idea of installing that plugin in the first place was ALSO because the change to style.css were NOT showing on the site either… so this is really annoying that I’ll have to toggle that plugin ON AND OFF to make the changes show on the site. WTF?

    #103498

    nickth
    Member
    Post count: 7

    P.S. There must be something StudioPress related causing this issue, because the ver number is showing up again on style.css?ver=2.0.2, which is a different version than style.css… where does this extra version reside and why doesn’t it update when I make changes to style.css? So annoying.

    #103506

    biztro
    Member
    Post count: 1

    I have the same problem!! I am trying to change the body font color and the style.css is changed but the source code is calling style.css?ver=3.0.2 which has the old color.

    Why? And how can I fix it?

    #103507

    nickth
    Member
    Post count: 7

    The only solution I’ve found that works is toggling Activate/Deactivate on the “Remove Static Query Strings” plugin, but this is obviously a hack and not an ideal solution to the bug from the hallowed StudioPress team.

    #103659

    nickth
    Member
    Post count: 7

    My PHP/WP dev figured it out.

    define(‘wp_cache’) had to be removed from wp-config.php in the root.

    I had remembered that w3tc is being installed with new WP installs, and oddly, it wasn’t in plugins, it was sitting in a folder OUTSIDE of plugins, as seen here: http://oi57.tinypic.com/9ihaif.jpg

    I just deleted that bloodsucker.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.