Trouble tranlating Read more text

Community Forums Forums Internationalization and Translations Trouble tranlating Read more text

This topic is: not resolved

This topic contains 8 replies, has 7 voices, and was last updated by  webkompaan 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8811

    sprite
    Participant

    Hi!

    I’m working on this multilanguage site:  majalis.ca English is the first/default language, French is the second language.

    I’m using the Maximum theme with the WPML plugin.  I just got Genesis translations plugin installed on my site (I didn’t install the plugin when I first started developing the site). Most of the texts translate without problems except the Read more buttons on the home page. The button says Read more on the French home page too.. :-(

    I’ve gotten my knickers in a twist trying to figure out what is wrong. The WPML comlains that the French .mo file is missing (whatever that is) Might that be the problem?

    French
    fr
    .mo
    File not found!
    3.4.1 ( January 1, 2013 @20:30)
    3.4.1

    Satu

     

    #9939

    Remkus de Vries
    Moderator
    Post count: 25

    Is there a string in your <code>functions.php</code> file hardcoded?


    More about me: ForSite Media | Remkus de Vries.

    Genesis Plugins: Genesis Translations | Genesis Toolbar+ | Genesis Prose Exporter
    Make the CSS editing part of your life easier for yourself – use Google Chrome and its Developers Tools.

    #98430

    tkr@vidensbanken.com
    Member
    Post count: 1

    I do get the exact sam problem in the Executive theme – all the [Read More...] dosn’t translate even though I have used the WPML String translation – and there is no hardcoded in the functions.php. I do however have the same missing .mo file, but that should not matter as I didn’t choose to translate via .mo, right? And everything else translates perfectly.

    Any other ideas?

    //Tanja

    #99034

    diessi
    Member
    Post count: 1

    Also same problem here with the Executive Theme. WPML doesn’t show the strings in the Read more field that are coming from the Genesis widgets. Apparently this field is not translatable. To register a string by hand for WPML I normally add
    [wpml-string context="wpv-views"]Read More[/wpml-string] to it, but Genesis is just showing the whole shortcode instead.

    Dear support, what to do? Any feedback much appreciated.

    Regards,

    #100679

    miriamg
    Member
    Post count: 3

    I get the exact same problem. I’m testing the Foodie template and using the Genesis translations plugin for translating into Spanish. The “Read more” piece doesn’t translate, all other pieces do. I’m not into tweaking code really…
    Please help!
    Best,
    Miriam

    #100680

    Daniel Bailey
    Participant
    Post count: 3

    If you meant the read more text from the featured posts and pages widgets then until those strings are made translatable you could try using widget logic as I have on a few sites in the past.

    http://wordpress.org/plugins/widget-logic/

    #100681

    Remkus de Vries
    Moderator
    Post count: 25

    Unfortunately this means the Foodie theme is not coded properly – at least regarding internationalisation – and you have no other option than to change this in your, presumably, functions.php file.


    More about me: ForSite Media | Remkus de Vries.

    Genesis Plugins: Genesis Translations | Genesis Toolbar+ | Genesis Prose Exporter
    Make the CSS editing part of your life easier for yourself – use Google Chrome and its Developers Tools.

    #100683

    miriamg
    Member
    Post count: 3

    Thank you Remkus, I will contact the Foodie theme designers then.
    Regards,
    Miriam

    #112352

    webkompaan
    Participant
    Post count: 17

    I’m having the same issue with this widget. In my case the Show Category Archive Link cannot be translated using WPML. Who should I contact about this? Is this part of a Genesis plugin?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.