Tutorial-Adding Genesis Box to Post-Breaking my site

Community Forums Forums General Discussion Tutorial-Adding Genesis Box to Post-Breaking my site

This topic is: not resolved

This topic contains 10 replies, has 4 voices, and was last updated by  rfmeier 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #82181

    marklove
    Member
    Post count: 8

    Im doing the tutorial ‘How To Add a Genesis Box to my Post’ and getting the ‘white screen of death’.

    When I add the code snippet below ( registering the widget area) into my child functions.php my site breaks and I get the white screen. I also changed the ‘themename’ to my theme but that didnt help. This happens when I use the original code in the tutorial as well as when I update the hooks to html 5 as shown below:

    //* Register Genesis box widget area
    genesis_register_sidebar( array(
    ‘id’ => ‘genesis-box’,
    ‘name’ => __( ‘Genesis Box’, ‘themename’ ),
    ‘description’ => __( ‘This is a widget area that can be placed after the post’, ‘themename’ ),
    ) );

    What am I doing wrong?

    Thanks much,
    Mark

    http://its a mamp site
    #82185

    Anita
    Blocked
    Post count: 7712

    Mark sure all of your apostrophes are correct. I typically use Notepad or Notepad++ to make sure.

    #82200

    marklove
    Member
    Post count: 8

    I’m using Coda 2. When you say ‘correct’ do you mean the placement of them, or something else?
    I guess the placement is correct because it’s copied and pasted. Are you saying maybe they didnt interpret correctly? Are they supposed to be single or double? or hmm…what? I’ll look at them again.

    #82202

    marklove
    Member
    Post count: 8

    I just re-typed everything and the same problem happens, so what else might be the problem?
    Im using this genesis base theme here:

    http://stewartchamberlain.com/themes/genesis-html5-base-child-theme/

    Thank you for your help!

    #82203

    Anita
    Blocked
    Post count: 7712

    Oh, then you might want to reach out to Stewart directly as that’s his Child Version. That is not the Studiopress Sample Child Theme. Stewart has added other code in there.

    #82204

    marklove
    Member
    Post count: 8

    Ok. I have reached out to him and waiting his reply. I can easily switch over to your sample theme and give it a try. Do you recommend that I learn genesis using the genesis sample?

    #82209

    marklove
    Member
    Post count: 8

    I switched back over to the genesis sample theme and that one is not breaking, so Im going to stick with the sample theme for now.
    Thanks much,
    Mark

    #82218

    Anita
    Blocked
    Post count: 7712

    Ok, if you need more help just post back over hear.

    #82227

    marklove
    Member
    Post count: 8

    Ok. My site is not breaking, but no trace of the post box.

    I have added the following code into my genesis sample theme functions.php file:

    //* Register Genesis box widget area
    genesis_register_sidebar( array(
    ‘id’ => ‘genesis-box’,
    ‘name’ => __( ‘Genesis Box’, ‘themename’ ),
    ‘description’ => __( ‘This is a widget area that can be placed after the post’, ‘themename’ ),
    ) );

    //* Hook Genesis box widget area after post content
    add_action( ‘genesis_entry_footer’, ‘sp_genesis_box’, 9 );
    function sp_genesis_box() {
    if ( is_single( ) )
    genesis_widget_area( ‘after-post’, array(
    ‘before’ => ‘<div class=”genesis-box widget-area”>’,
    ‘after’ => ‘</div>’,
    ) );
    }

    I have added the following code into my genesis sample theme style.css file:
    /* Genesis Box
    ——————————————— */

    .genesis-box {
    background: #f5f5f5;
    border: 1px solid #ddd;
    margin-top: 20px;
    padding: 20px;
    }

    .genesis-box h4 {
    font-size: 18px;
    font-weight: normal;
    margin-bottom: 10px
    padding: 0;
    text-transform: none;
    }

    .genesis-box .alignright {
    background: #fff;
    border: 1px solid #ddd;
    float: right;
    margin: 0 0 5px 10px;
    padding: 7px;
    }

    The Genesis Box widget box is displaying in my widget area in wp dash. I have included a text widget with the html from the tutorial inside the Genesis Box widget.

    So we should be good to go.

    Upon inspecting my single post displays in the browser, there is only entry meta below the single posts and no evidence of a widget.
    What am I doing wrong?

    #105371

    maziermedia
    Member
    Post count: 5

    I’m in the same boat, after reading the tutorial, I do have the widget, I place Text in there, add the HTML, and nothing shows. Did you find an answer?

    #105547

    rfmeier
    Participant
    Post count: 597

    Hello,

    @marklove, you have the incorrect id as the first argument in the genesis_widget_area function. I adjusted the code to have to correct id below;

    I hope this helps.


Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.