Warning: printf() [function.printf] error on Metro Theme :S

Community Forums Forums General Discussion Warning: printf() [function.printf] error on Metro Theme :S

This topic is: not resolved

This topic contains 8 replies, has 3 voices, and was last updated by  nciske 1 year ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #32120

    pluzito
    Participant
    Post count: 12

    Hello everygone, I’m gettin the following error appearing under the Dashboar/Genesis/theme settings below the boxes of Header scripts and footer scripts. My url is: DoggsHipHop.com

    Warning: printf() [function.printf]: Argument number must be greater than zero in/www/doggs.com.ar/htdocs/hiphop/wp-content/themes/genesis/lib/admin/theme-settings.php on line 717

    The site runs well, but this warning sounds pretty ugly. Thanks!

    #32256

    nciske
    Participant
    Post count: 15

    Warnings are not generally “harmful” — and unless your site is in development you shouldn’t be seeing them output in the page like this. Is suspect it’s an uninitialized option and would go away once you save the form once (these ‘fresh install’ bugs are always hard to catch as a developer).

    I’d make sure WP_DEBUG is disabled on your live server… and I’d suggest reporting this in the customer forum for Metro so the devs can make sure it gets fixed in the next version.

    http://codex.wordpress.org/Editing_wp-config.php#Debug

    #32259

    snakeair
    Participant
    Post count: 147

    I’ve been using metro since it was released and never scene this error message anywhere in my dashboard. Could be related to a plugin you have enabled or changes you have made to one of the theme files that’s causing this.

    Are you running the latest version of Genesis Framework?

    #32453

    pluzito
    Participant
    Post count: 12

    I’ve tried with a new database import and disabling all plugins, the error continues. I figured out that the error stops when I deleted both es_ES.mo and es_ES.po from genesis/lib/languages :S any suggestion? I need my blog translated to spanish. Thank you very much for your help

    #32455

    pluzito
    Participant
    Post count: 12

    No doubt, is the .mo and .po files in the genesis directory that triggers that trouble. I’ve went back to my old installation and delete them and the error dissapeared. How can I get thos translation files for spanish working? thanks

    #32457

    nciske
    Participant
    Post count: 15

    Report the issue to the SP support team — there seems to be an issue in the language file that is causing the PHP Warning.

    http://my.studiopress.com/help/

    If you’re feeling adventurous you can edit the PO file and try to fix the issue yourself (it’s likely a missing translated string) and attempt to generate a new .mo file.

    PO Edit is a freeware language file editor:

    http://www.poedit.net

    #32503

    pluzito
    Participant
    Post count: 12

    Thanks for the help. I’ve tried filling al the blank translations and the problem continues. Only when I delete the files from my FTP the problem is gone. Then I’ve tried to use the Genesis 1.8 translation for spanish instead of 1.9 and the same problem occurs. I’m using that Poedit soft, maybe any problem with it? I have to upload both es_ES.mo and es_ES.po? thanks for your help, I’m stucked with this

    #32504

    pluzito
    Participant
    Post count: 12

    If is simple as uploading two files via FTP to get Genesis tranlated, I prefer that than charging my blog with another plugin (Genesis Translation) or much code on the Functions.php. Thanks

    #32508

    nciske
    Participant
    Post count: 15

    It’s clearly not a simple fix — I’d recommend you open a support ticket.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.