Where is Setting for Number of Posts in Minimum Pro Theme Front Page?

Community Forums Forums General Discussion Where is Setting for Number of Posts in Minimum Pro Theme Front Page?

This topic is: not resolved

This topic contains 12 replies, has 4 voices, and was last updated by  moxiegirl 1 year, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #61123

    scoe
    Participant
    Post count: 57

    Hi,

    I’m wondering how to control the number of posts on the front page of Minimum Pro theme.

    The Minimum Pro set up instructions says to try setting “Genesis/ Theme Settings/ Blog Page Template/ Number of Posts” to 6. But this does not work. I have 7 posts on my front page. (Please do not post links to the setup instructions.)

    FYI: In the old Minimum (not pro) theme the number of posts on the front page was set in “General Settings/ Reading /Blog Pages Show at Most…” and that worked. (Contrary to setup instructions even then.)

    In the new Minimum Pro, neither setting works. I just have 7 posts. I would like two posts.

    I have other concerns (like the length of content), but I’m keeping it simple. Where is that number of posts coming from? Any ideas? This is a beautiful theme and I would love to get this the way the client wants.

    Thanks,

    Sheryl

    #61137

    scoe
    Participant
    Post count: 57

    Just posting here in case others are interested… I still have no idea where the number of posts is controlled, but the widgetized home page gives you more control.

    #61184

    jbculp
    Participant
    Post count: 119

    I think its under Reading Settings – standard wordpress settings page. This is from the theme instructions… is this what you want?

    How to Configure the Home Page
    Blog Post Display

    The number of posts displayed can be changed by navigating to Settings > Reading in the WordPress admin panel and setting the “Blog pages show at most” option to the number of excerpts you would like to have display on the home page.

    minimum-reading-settings

    Here is the tutorial link:

    #62100

    scoe
    Participant
    Post count: 57

    Hi jbclup,

    Thanks for the response. I am following the tutorial exactly and the number of posts does not respond to changes in the “Blog pages show at most” option. Not in Minimum Pro with the desired number of posts at 2.

    Still trying…

    Thanks,

    Sheryl

    #62105

    jbculp
    Participant
    Post count: 119

    Sheryl,

    I disabled my grid entirely but put it back and tested it successfully. Look into these things.

    #1 The grid is called in the front-page.php at line 88 in the original file. The code looks like this:

    //* Genesis grid loop
    function minimum_grid_loop_helper() {

    if ( function_exists( 'genesis_grid_loop' ) ) {
    genesis_grid_loop( array(
    'features' => 0,
    'feature_image_size' => 0,
    'feature_content_limit' => 0,
    'grid_image_size' => 0,
    'grid_content_limit' => 250,
    'more' => __( '[Read more]', 'minimum' ),
    ) );
    } else {

    genesis_standard_loop();

    }

    If you change the features number from 0 to 1 for example, the feature of controlling the grid form within WordPress goes away and that number of posts appear on the home page but NOT in a grid. Putting it back to 0 makes things happy again.

    #1 Make sure you have not commented out this section or changed the values.
    #2 In WordPress you want to make sure you are changing it in the right place… Settings, Reading, Blog pages show at most and your # of posts desired. I am not a programmer so can’t say if any other changes on this page would impact the grid but the theme has its own homepage so you would want Front Page Displays to be the default (Your Latest Posts) and leave Full Text Summary selected. Not sure if this last item impacts only the feed or the grid but the character limit is set in front-page.php at line 97.

    Try setting things to those settings, clear your cache and refresh. If your front-page.php data is altered, put it back to default and ftp a new version back up. Beyond that I’m not sure I’ll be much help. If your front-page.php file was not altered and your WordPress reading settings are OK, then you may have a plugin conflicting???? Did you install Genesis-Grid-Loop plugin? If so, disable that.

    Let me know how it goes

    John

    #62106

    scoe
    Participant
    Post count: 57

    Hi jbclup,

    Looks like you were right. I does not include Sticky Posts in the count, which surprised me. Totally embarrassing.

    “Blog pages show at most” is set to 1. So with 2 stickies that gives me 3 posts on the home page. I wish there was a way to control the total number of posts. Hate to think that unsticking a post would run the design. Live and learn.

    So thanks!!

    – Sheryl

    For others reading this: The Genesis Settings controls pages using the blog template.

    #62108

    jbculp
    Participant
    Post count: 119

    Sheryl,

    I’m sure there would be a filter you could add to the front-page.php to strip out stick posts but that’s above my pay grade. :)

    jc

    #62165

    scoe
    Participant
    Post count: 57

    Hi jbculp,

    No worries. I’m going to post to support. Just to make sure I’ve done all I can. Thanks again for your answers and encouragement. I’ll post again here if I learn anything different.

    Take care,

    Sheryl

    #62171

    scotm
    Participant
    Post count: 35

    Check the functions.php file. I believe it’s set to 6.

    #62190

    jbculp
    Participant
    Post count: 119

    scotm,

    I think the reference in the functions.php is for portfolio items not posts but I could be wrong.

    john

    #63550

    moxiegirl
    Participant
    Post count: 73

    I changed my functions php where it showed 6 to 1, but no change. Any more ideas?

    #63588

    jbculp
    Participant
    Post count: 119

    It’s not the functions.php That setting is for the portfolio display. The number is controlled by WordPress in the reading settings per the theme instructions. According to Sheryl (scoe) it doesn’t count sticky posts so presumably they inflate the count. So if you wanted 4 and had 2 sticky posts you’d set the WordPress settings to 2.

    If you only want 1 then you may have to mess with the CSS to make it full width. Look for something like this in your style.css and modify the width as appropriate:

    .genesis-grid-even, .genesis-grid-odd {
        border-bottom-color: #F5F5F5;
        border-bottom-style: solid;
        border-bottom-width: 1px;
        margin-bottom: 3rem;
        padding-bottom: 0;
        padding-left: 0;
        padding-right: 0;
        padding-top: 0;
        width: 47%;
    }

    Hope that helps.

    JohnC

    #63877

    moxiegirl
    Participant
    Post count: 73

    Oh, okay. Thanks for that info John!

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.